Vega color names

Hello everyone,

Nathan just proposed names for the new vega colors:
https://github.com/matplotlib/matplotlib/issues/7248

As Antony mentioned, getting the names right is quite important as
this is probably going to be the default for the next 10 years.

Cheers,
N

I just created a new conda environment with Matplotlib included, and it duly installed matplotlib: 2.0.0-np111py27_0. It installed PyQt5 by default, whereas I need PyQt4, but when I installed PyQt4 (conda install pyqt=4), it automatically downgraded Matplotlib to 1.5.1.

···

--------
The following packages will be DOWNGRADED due to dependency conflicts:

    matplotlib: 2.0.0-np111py27_0 --> 1.5.1-np111py27_0
    pyqt: 5.6.0-py27_2 --> 4.11.4-py27_4
    qt: 5.6.2-0 --> 4.8.7-4
--------
Is PyQt5 really a dependency for Matplotlib v2? I have been testing release candidate versions of Matplotlib v2 without any problem. This will cause headaches to my users who want the latest features.

Ray
--
Ray Osborn, Senior Scientist
Materials Science Division
Argonne National Laboratory
Argonne, IL 60439, USA
Phone: +1 (630) 252-9011
Email: ROsborn@...1285...

no, pyqt5 is not a dependency for matplotlib. this looks like a conda packaging issue.

Side note: the sourceforge mailing list is deprecated. Please use the python.org version instead (you’ll have to re-register).

Ben Root

···

On Thu, Feb 2, 2017 at 11:43 AM, Osborn, Raymond <rosborn@…1098…85…> wrote:

I just created a new conda environment with Matplotlib included, and it duly installed matplotlib: 2.0.0-np111py27_0. It installed PyQt5 by default, whereas I need PyQt4, but when I installed PyQt4 (conda install pyqt=4), it automatically downgraded Matplotlib to 1.5.1.


The following packages will be DOWNGRADED due to dependency conflicts:

matplotlib: 2.0.0-np111py27_0 --> 1.5.1-np111py27_0

pyqt:       5.6.0-py27_2      --> 4.11.4-py27_4

qt:         5.6.2-0           --> 4.8.7-4

Is PyQt5 really a dependency for Matplotlib v2? I have been testing release candidate versions of Matplotlib v2 without any problem. This will cause headaches to my users who want the latest features.

Ray

Ray Osborn, Senior Scientist

Materials Science Division

Argonne National Laboratory

Argonne, IL 60439, USA

Phone: +1 (630) 252-9011

Email: ROsborn@…1285…


Check out the vibrant tech community on one of the world’s most

engaging tech sites, SlashDot.org! http://sdm.link/slashdot


Matplotlib-devel mailing list

Matplotlib-devel@…1041…sourceforge.net

https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

It appears that the build of matplotlib in conda-forge does not require pyqt5:
https://github.com/conda-forge/matplotlib-feedstock/blob/master/recipe/meta.yaml

So in your case, I would do:

conda remove pyqt5 matplotlib

conda install --channel=conda-forge matplotlib

···

On Thu, Feb 2, 2017 at 8:48 AM, Benjamin Root <ben.v.root@…714…> wrote:

no, pyqt5 is not a dependency for matplotlib. this looks like a conda packaging issue.

Side note: the sourceforge mailing list is deprecated. Please use the python.org version instead (you’ll have to re-register).

Ben Root


Check out the vibrant tech community on one of the world’s most

engaging tech sites, SlashDot.org! http://sdm.link/slashdot


Matplotlib-devel mailing list

Matplotlib-devel@…1041…sourceforge.net

https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

On Thu, Feb 2, 2017 at 11:43 AM, Osborn, Raymond <rosborn@…1285…> wrote:

I just created a new conda environment with Matplotlib included, and it duly installed matplotlib: 2.0.0-np111py27_0. It installed PyQt5 by default, whereas I need PyQt4, but when I installed PyQt4 (conda install pyqt=4), it automatically downgraded Matplotlib to 1.5.1.


The following packages will be DOWNGRADED due to dependency conflicts:

matplotlib: 2.0.0-np111py27_0 --> 1.5.1-np111py27_0

pyqt:       5.6.0-py27_2      --> 4.11.4-py27_4

qt:         5.6.2-0           --> 4.8.7-4

Is PyQt5 really a dependency for Matplotlib v2? I have been testing release candidate versions of Matplotlib v2 without any problem. This will cause headaches to my users who want the latest features.

Ray

Ray Osborn, Senior Scientist

Materials Science Division

Argonne National Laboratory

Argonne, IL 60439, USA

Phone: +1 (630) 252-9011

Email: ROsborn@…746…285…


Check out the vibrant tech community on one of the world’s most

engaging tech sites, SlashDot.org! http://sdm.link/slashdot


Matplotlib-devel mailing list

Matplotlib-devel@…1035…orge.net

https://lists.sourceforge.net/lists/listinfo/matplotlib-devel