two questions

Abraham Schneider wrote:

    >> Just tried the 'rm -fr ...../site-packages/matplotlib', and I
    >> still get the same behavior. Also, if that were the cause, then
    >> shouldn't it also crash outside of ipython as well?

    > I should note that I'v also seen this same crash with
    > 0.83.2 official.

    > I haven't bothered to track it down, because I hardly
    > ever use GTK except when testing for problems on the
    > list.

    > It may not happen outside of ipython, if somehow the
    > crash is triggered by the threading tricks which ipython
    > uses to enable GTK interactive use. Nasty...

OK, I just checked the archives. This definitely has cropped up
before on ipython w/ matplotlib under 0.83.2. Steve Schmerler
reported it on the user's list and we had some extensive discussions
on and off list and never found the cause. He eventually just started
using the debian package at which point the bug hunt was terminated.

Fernando, if you can replicate it on your box with your current
install, maybe you can set me up with an account and I'll log in and
see if I can trace it. It looks like it's going to be a
gtk/ipython/matplotlib/threading multi-headed monster.