trouble installing new matplotlib on mac os x

per freem <perfreem@...287...> writes:

i am trying to install matplotlib-0.99 on a mac os x machine, with the
following python:

Python 2.5.1 (r251:54863, Jan 13 2009, 10:26:13)
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin

I think that's the system Python (/usr/bin/python), while the installer
package works with the framework Python (/usr/local/bin/python). See:

http://matplotlib.sourceforge.net/faq/installing_faq.html#os-x-questions
http://www.python.org/download/mac/
http://www.python.org/download/releases/2.5.4/

i also cannot where the new version was installed. does anyone know
where the files for the new matplotlib should be? they are not in
/Library/Frameworks/Python2.5/ it seems.

It should be in

/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages

if i do:

locate matplotlib | grep 0.99

nothing comes up. i only see files related to the older matplotlib
when i do "locate matplotlib" in the shell.

The locate database is only updated weekly (and that's assuming that you
keep your Mac running in the early hours in which the update is run by
default). Try

sudo periodic weekly

to update the database if you want locate to find recently created
files. The update can take quite some time.

any ideas how i can install this? i wanted to try the .egg
installation with "easy_install" but when i do:

easy_install matplotlib

it matches to a 0.98 version of matplotlib, not 0.99.

easy_install can be really bothersome. If you have an easy-install.pth
file in your site-packages directory, edit it and remove references to
the old version of matplotlib.

···

--
Jouni K. Sepp�nen
http://www.iki.fi/jks