_tkinter problem

Your python is missing the _tkinter library, so it cannot use Tkinter.

Normally if you build from source then all you have to do is build and
install tcl and tk first, then build python and it should find the
tcl/tk and build _tkinter (the library that links to Tcl/Tk and allows
Tkinter to work).

If you installed from an RPM or some such then perhaps you need to get
some additional RPMs.

If you have additional questions about installing python with Tkinter
support I suggest you post to the python-tkinter mailing list
(gmane.comp.python.tkinter on gmane).

-- Russell

In article <7483F0868D484AE6A0A7DDB5BFBFDFF5@...2660...>,

ยทยทยท

"Paul Simon" <psimon@...436...> wrote:

I have the "tkinter" problem and need some assistance to straighten it out.
>From the web page "http://wiki.python.org/moin/TkInter" I tested as in "step
1" and cannot import "_tkinter." I do not have that file on my computer, but
do have tkinter.py in /usr/local/lib/python2.6/lib-tk. as well as the
directories /usr/lib/tk8.5 and /usr/lib/tcl8.5.
This matplotlib and python stuff is great, but the documentation frequently
feels like it is just a bit out of my grasp. I realize that all of this is
free but I understand the instructions on the web page to repair only to the
point of confusion. I'm not an expert. How do I modify my python
configuration? Is there a file that needs to be edited? Which setup.py file
do I use? Make? or python setup.py build and python setup.py install?
Thanks. I appreciate your help.
Paul Simon

------------------------------------------------------------------------------
Enter the BlackBerry Developer Challenge
This is your chance to win up to $100,000 in prizes! For a limited time,
vendors submitting new applications to BlackBerry App World(TM) will have
the opportunity to enter the BlackBerry Developer Challenge. See full prize
details at: http://p.sf.net/sfu/Challenge