Simple plot command fails


I am trying to get matplotlib (0.64) up and running. When I run the
following commands
  from matplotlib.matlab import *
I get an error message (shown below), the figure window draws with the
buttons on the bottom, but no plot is drawn. I have tried this with the
GTKAgg and TkAgg backends and they both give the same error. If it matters,
I am using numarray.

Any help/suggestions would be appreciated.


Python 2.2.2 (#1, Feb 24 2003, 19:13:11)
[GCC 3.2.2 20030222 (Red Hat Linux 3.2.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

from matplotlib.matlab import *

<matplotlib.figure.Figure instance at 0x86cea2c>


[<matplotlib.lines.Line2D instance at 0x87470cc>]


.py: 83: GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main
  self.warn(message, DeprecationWarning)
Traceback (most recent call last):
"/local/lib/python2.2/site-packages/matplotlib/backends/ ",
line 96, in callback
    else: self.draw()
"/local/lib/python2.2/site-packages/matplotlib/backends/ ",
line 44, in draw
line 310, in draw
  File "/local/lib/python2.2/site-packages/matplotlib/", line 254,
in d raw
    for a in self.axes: a.draw(renderer)
  File "/local/lib/python2.2/site-packages/matplotlib/", line 963, in
dra w
  File "/local/lib/python2.2/site-packages/matplotlib/", line 478, in
dra w
  File "/local/lib/python2.2/site-packages/matplotlib/", line 132, in
dra w
    if midPoint and self.tick1On: self.tick1line.draw(renderer)
  File "/local/lib/python2.2/site-packages/matplotlib/", line 234,
in dr aw
    xt, yt = self._transform.numerix_x_y(x, y)
ValueError: x and y must be equal length sequences

What OS version/distribution are you running? Did you built matplotlib
yourself? Any errors in the build? What is in your $HOME/.matplotlibrc


On Wed, 2004-11-17 at 12:44 -0500, Zelakiewicz, Scott (Research) wrote:

Any help/suggestions would be appreciated.

Stephen Walton, Professor of Physics and Astronomy,
California State University, Northridge