Problems after upgrading to

I just upgraded from 0.98.3 to on my Mac (OS X 10.4.11) because I wanted some of the new legend features, and now have two strange errors.

  1. When I run a script that creates a plot, the terminal window (either a command prompt or ipython) is now frozen until I have closed the plot window. Previously, this same script would create the plot, but then allow me to access the prompt.

  2. I seem to no longer be able to zoom in or out on the plots. Additionally, with 0.98.3 I used to be able to dynamically move the plots (I would see the figure move as I dragged it), but now the plot doesn’t move until after I’ve released the mouse button, making it harder to see how far I’ve moved it.

I’ve noticed that my old backend was ‘TkAgg’, while defaults to ‘MacOSX’. I’ve tried running

matplotlib.rcParams[‘backend’] = ‘TkAgg’

at the top of my script, but that doesn’t seem to do anything (I have the same problems). Does anyone have any idea what’s happening or how I can fix these problems? If not I may need to go back to 0.98.3 for now. Thanks.