Problem to plot when I use VPN

I have problem with plotting when I am using VPN, which stop plotting by such error:

Error: failed to send plot to http://100.0.0.1:64312    # ### <-- I have changed the values here
Traceback (most recent call last):
  File "C:\Program Files\JetBrains\PyCharm 2020.3.3\plugins\python\helpers\pycharm_display\datalore\display\display_.py", line 60, in _send_display_message
    urlopen(url, buffer)
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\urllib\request.py", line 222, in urlopen
    return opener.open(url, data, timeout)
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\urllib\request.py", line 525, in open
    response = self._open(req, data)
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\urllib\request.py", line 542, in _open
    result = self._call_chain(self.handle_open, protocol, protocol +
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\urllib\request.py", line 502, in _call_chain
    result = func(*args)
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\urllib\request.py", line 1383, in http_open
    return self.do_open(http.client.HTTPConnection, req)
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\urllib\request.py", line 1358, in do_open
    r = h.getresponse()
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\http\client.py", line 1348, in getresponse
    response.begin()
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\http\client.py", line 316, in begin
    version, status, reason = self._read_status()
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\http\client.py", line 277, in _read_status
    line = str(self.fp.readline(_MAXLINE + 1), "iso-8859-1")
  File "C:\Users\Ali\anaconda3\envs\PFC_FiPy\lib\socket.py", line 669, in readinto
    return self._sock.recv_into(b)
ConnectionResetError: [WinError 10054] An existing connection was forcibly closed by the remote host

Because I need to turn VPN on for my works, this issue forced me to disconnect VPN for plotting and connect it again frequently. Is there any way to get rid of this problem?

None of that traceback is in Matplotlib. It looks like an issue with PyCharm’s display backend. You will have to ask them for support on this.

Thanks. I asked it there:
https://youtrack.jetbrains.com/issue/PY-57179/Problem-to-plot-when-I-use-VPN-WinError-10054-An-existing-connection-was-forcibly-closed-by-the-remote-host