matplotlib/wxmpl/numpy conflict on windows xp: runtime error, C-API ?

Hi,

···

I'm trying to install a matplotlib+wxmpl app I wrote on Linux on a Windows XP machine. It crashes starting with the following error:
-----
C:\Documents and Settings\Principale\Desktop\Python\Hooke>python hooke.py
Traceback (most recent call last):
   File "hooke.py", line 12, in ?
     import wxmpl
   File "C:\Programmi\Python23\Lib\site-packages\wxmpl.py", line 26, in ?
     from matplotlib.axes import PolarAxes, _process_plot_var_args
   File "C:\PROGRA~1\Python23\Lib\site-packages\matplotlib\axes.py", line 23, in
?
     from contour import ContourSet
   File "C:\PROGRA~1\Python23\Lib\site-packages\matplotlib\contour.py", line 18,
in ?
     import _contour
   File "C:\PROGRA~1\Python23\Lib\site-packages\matplotlib\_contour.py", line 17,
  in ?
     from matplotlib._ns_cntr import *
RuntimeError: module compiled against version 90709 of C-API but this version of numpy is 1000000
-----

I installed the latest sourceforge stable (not CVS/SVN) versions of matplotlib, numpy and wxmpl as of today.

I'm quite puzzled, I guess I understand what the error is (different gcc versions?), but how can I get around it? Do I need to recompile numpy/matplotlib?

m.

--
Massimo Sandal
University of Bologna
Department of Biochemistry "G.Moruzzi"

snail mail:
Via Irnerio 48, 40126 Bologna, Italy

email:
massimo.sandal@...898...

tel: +39-051-2094388
fax: +39-051-2094387

I am guessing you installed numpy1.0b1. You need to use 0.9.8.

···

On 7/24/06, massimo sandal <massimo.sandal@...898...> wrote:

Hi,
I'm trying to install a matplotlib+wxmpl app I wrote on Linux on a > Windows XP machine. > > It crashes starting with the following error:
-----
C:\Documents and Settings\Principale\Desktop\Python\Hooke>python hooke.py
Traceback (most recent call last):
   File "hooke.py", line 12, in ?
     import wxmpl
   File "C:\Programmi\Python23\Lib\site-packages\wxmpl.py", line 26, in ?
     from matplotlib.axes import PolarAxes, _process_plot_var_args
   File "C:\PROGRA~1\Python23\Lib\site-packages\matplotlib\axes.py",
line 23, in
?
     from contour import ContourSet
   File "C:\PROGRA~1\Python23\Lib\site-packages\matplotlib\contour.py",
line 18,
in ?
     import _contour
   File "C:\PROGRA~1\Python23\Lib\site-packages\matplotlib\_contour.py",
line 17,
  in ?
     from matplotlib._ns_cntr import *
RuntimeError: module compiled against version 90709 of C-API but this
version of numpy is 1000000
-----

I installed the latest sourceforge stable (not CVS/SVN) versions of
matplotlib, numpy and wxmpl as of today.

I'm quite puzzled, I guess I understand what the error is (different gcc
versions?), but how can I get around it? Do I need to recompile
numpy/matplotlib?

m.

--
Massimo Sandal
University of Bologna
Department of Biochemistry "G.Moruzzi"

snail mail:
Via Irnerio 48, 40126 Bologna, Italy

email:
massimo.sandal@...898...

tel: +39-051-2094388
fax: +39-051-2094387

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys -- and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Charlie Moad ha scritto:

I am guessing you installed numpy1.0b1. You need to use 0.9.8.

Thanks a lot. I uninstalled 1.01b1 and installed 0.9.8 and everything workes perfectly.

Thanks again,
Massimo

···

--
Massimo Sandal
University of Bologna
Department of Biochemistry "G.Moruzzi"

snail mail:
Via Irnerio 48, 40126 Bologna, Italy

email:
massimo.sandal@...898...

tel: +39-051-2094388
fax: +39-051-2094387