matplotlib-py3 branch won't show in Ubuntu 10.04

How Would I set the backend to Tk?

Do I have to change something in the matplotlibrc file? Maybe I have to specify where Tk is located?

Any guidance would be helpful.

Thanks again,
Jorge Garcia


On Sun, Jul 3, 2011 at 6:55 PM, Jorge Garcia <jgarc063@…3663…> wrote:

Hi Chris,

No I haven’t been able to yet, but I’m hoping to get it working with a little help. Matplotlib I think is the last library that needs to be ported to finally make the transition to Python3 feasible for the mainstream Python users. That and maybe wxPython, but since I don’t use wxPython it’s not really an issue for me.

Best Regards,

On Sat, Jul 2, 2011 at 7:04 PM, Chris Edwards <cbhe@…3444…> wrote:

Hi Jorge,

I had the same problem with Python(xy) and couldn’t get help so I went back to an earlier version that worked for me.

Did you solve the problem?


On 30/06/2011, at 12:46 AM, Jorge Garcia wrote:


I was trying to test out the Python 3 development version with the first plot shown in the pyplot tutorial. Everything seems to work ok until I go

at which point nothing happens, I don’t see a plot. Python accepts the command and is waiting for a new command but I have no plot.

I’ve tried changing the backend in the matplotlibrc file to TkAgg, but I still get nothing, in fact now when I try to import matplotlib I get a traceback error that name -tkagg is not defined, seems like it might be something in the module.

Can anyone lend a hand?


Jorge Garcia

All of the data generated in your IT infrastructure is seriously valuable.

Why? It contains a definitive record of application performance, security

threats, fraudulent activity, and more. Splunk takes this data and makes

sense of it. IT sense. And common sense.

Matplotlib-users mailing list