ImportError: No module named 'mpl_toolkits'

To matplotlib-users,

When I do this on Linux:
from mpl_toolkits.basemap import Basemap

Then I get this error:
ImportError: No module named 'mpl_toolkits'

I also ran apt-get, but I still get the error:
sudo apt-get install python-mpltoolkits.basemap

What am I doing wrong? I also tried to get it to work on Mac with no luck.

Thanks,
Tommy

To matplotlib-users,

When I do this on Linux:
from mpl_toolkits.basemap import Basemap

Then I get this error:
ImportError: No module named 'mpl_toolkits'

Sounds like it might be a problem with the particular versions of matplotlib and basemap; there was a change in the way we handle namespace packages like mpl_toolkits.

I also ran apt-get, but I still get the error:
sudo apt-get install python-mpltoolkits.basemap

What am I doing wrong? I also tried to get it to work on Mac with no luck.

Lots of possibilities, so without looking to see exactly what is on each system (Linux and Mac), it is impossible to say what the problem is.

For both systems, one easy solution is to use Anaconda. Basemap is not included in the basic installation, but can be added via "conda install basemap". Recommended.

Eric

ยทยทยท

On 2014/07/13, 12:05 AM, Tommy Carstensen wrote:

Thanks,
Tommy

------------------------------------------------------------------------------
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users