Fw: Control of thread/program not returning to ipython after creating a plot.

Sorry - I should have replied to all to continue the thread on the


Begin forwarded message:

Date: Wed, 17 Nov 2010 18:22:25 -0700
From: Collin Day <dcday137@...287...>
To: Benjamin Root <ben.root@...1304...>
Subject: Re: [Matplotlib-users] Control of thread/program not returning
to ipython after creating a plot.

On Wed, 17 Nov 2010 19:00:54 -0600 Benjamin Root <ben.root@...1304...> wrote:

I tried that - same results. I did continue to try different backends
- TkAgg lets me call figure(), pulls up an empty figure and then I call
  plot(x,y) and the plot appears as expected. That backend is fine
  with me, but I am wondering if I have found a bug or some sort of
  interaction with GTK and / or wx. Here are snippets
  from /etc/matplotlib/matplotlibrc (when it doesn't work)

backend : WXAgg

# if you are runing pyplot inside a GUI and your backend choice
# conflicts, we will automatically try and find a compatible one for
# you if backend_fallback is True
#backend_fallback: True
interactive : True

so I have interactive set.


On Wed, Nov 17, 2010 at 6:54 PM, Collin Day <dcday137@...287...> > wrote:

> Either I updated something that changed Matplotlib's behavior or I
> am missing something, but when I make a plot in ipython, control is
> not returning to the prompt - I can't do anything until I close the
> plot. Here is exactly what I am doing:
> ipython --pylab
> x=arange(10)
> y=x**2
> figure()
> plot(x,y)
> show()
> Also, I am not sure if that is right. In the past I remember just
> being able to type plot() and the figure came up and control went
> back to ipython to continue. But I could be wrong.
> Then, if I want to do anything else, I have to close the window.
> The backend I am using is WXAgg. I also noticed that if I use the
> GTKAgg backend, control does not return to the prompt even after
> closing the plot. I have to hit ctl-c to get the prompt back. I
> have tried this both with ion() and ioff().
> I don't ever remember having to close the plot or hit control-c to
> keep working. I googled and did not really see anything relevant.
> Could anyone tell me what I am missing or what I need to do so that
> I can plot in ipython, leave the plot up, and then continue working?
> I have matplotlib 1.0.0 and ipython 0.10.1
> Thanks for any help!
Most likely, you were used to interactive mode being on. A new
installation of matplotlib might have over-written your matplotlibrc
file, resetting the option to False. Find your matplotlibrc file and
change interactive to True to get the behavior you want.

I hope that helps!

Ben Root