change return values from contour, contourf?

So, the big question is: is it OK, or at least potentially

    > OK, to change the pylab API for contour and contourf so that
    > they return a single object instead of a tuple?

It's fine with me. contour users are mostly power users, so they will
adapt, and the functionality is still relatively new so it is not too
deeply ingrained in people's apps. As I recall, I dumped most of the
contour functionality into the ContourHelpers class just to clean up, which was beginning to be dominated by all the contour code.

I think the idea of having a single object that controls all the
contour functionality is a good one, because it is easier to extend
w/o breaking argument passing symantics. In general, I think this
would be a good idiom for all plot objects (LinePlot, ScatterPlot,
ContourPlot, ImagePlot, etc...)

FYI, I applied you in/out ticks patch to CVS a couple of days ago.