Basemap installation on Ubuntu 9.04 (Jaunty Jackalope)

Hi all

I was wondering if anyone managed to find / install Basemap on a i386
machine running ubuntu 9.04 (Jaunty Jackalope) ...

I've installed the debs through synaptic, and I've tried without
success to compile
Basemap (0.99), with failure at the libgeos compilation. Trying to
install "old" .deb (python-basemap_0.99-0ads1_i386.deb) complains
about python 2.6

do I have to redo all the installation (numpy etc) using an older python (2.5) ?

thanks for any advice

···

--
_/\/¯¯¯¯¯¯\/\_ 33º49'45.24"S & 18º28'45.60"E
Dr. Nicolas Fauchereau
Senior Researcher
CSIR - NRE
Research Group: Ocean systems and climate
15 Lower Hope street, Rosebank 7700
South Africa
_/\/¯¯¯¯¯¯\/\_ 33º49'45.24"S & 18º28'45.60"E

2009/7/23 Nicolas <nicolas.fauchereau@...287...>:

Hi all

I was wondering if anyone managed to find / install Basemap on a i386
machine running ubuntu 9.04 (Jaunty Jackalope) ...

I've installed the debs through synaptic, and I've tried without
success to compile
Basemap (0.99), with failure at the libgeos compilation. Trying to
install "old" .deb (python-basemap_0.99-0ads1_i386.deb) complains
about python 2.6

do I have to redo all the installation (numpy etc) using an older python (2.5) ?

No. I have basemap 0.99.3 working with python 2.6 under Jaunty. What's
the compilation error you're getting? I can't immediately remember how
I did it (although it was not that long ago), but we can rework it
out.

Angus.

···

--
AJC McMorland
Post-doctoral research fellow
Neurobiology, University of Pittsburgh

2009/7/23 Angus McMorland <amcmorl@...287...>:

2009/7/23 Nicolas <nicolas.fauchereau@...287...>:

Hi all

I was wondering if anyone managed to find / install Basemap on a i386
machine running ubuntu 9.04 (Jaunty Jackalope) ...

I've installed the debs through synaptic, and I've tried without
success to compile
Basemap (0.99), with failure at the libgeos compilation. Trying to
install "old" .deb (python-basemap_0.99-0ads1_i386.deb) complains
about python 2.6

do I have to redo all the installation (numpy etc) using an older python (2.5) ?

No. I have basemap 0.99.3 working with python 2.6 under Jaunty. What's
the compilation error you're getting? I can't immediately remember how
I did it (although it was not that long ago), but we can rework it
out.

Found it, I think. I followed some instructions here [1], which are
copied below:

$ sudo apt-get install python-matplotlib python-numpy libgeos-dev
python-httplib2 python-imaging python-dev
$ tar xvfz basemap-0.99.2.tar.gz
$ cd basemap-0.99.2/
$ sudo checkinstall sudo python setup.py install

I hope that helps,

Angus.

···

--
AJC McMorland
Post-doctoral research fellow
Neurobiology, University of Pittsburgh