backend for matplotlib on NAS Lou (Thomas Caswell)

Just thought I report that I did get matplotlib working as desired on Lou.
It turns out that using the version of matplotlib and ipython that's loaded
by pkgsrc works (i.e. module load pkgsrc), if you set the backend to Qt4Agg
or GtkAgg in your matplotlibrc. In my case I had to remove from my path
the anaconda distribution that I had installed. I was also able to install
yt using pip (with the --user argument so it installs under ~/.local).

Regards,
Jon

···

On Tue, Feb 6, 2018 at 12:00 PM, <matplotlib-users-request at python.org> wrote:

Date: Tue, 06 Feb 2018 02:44:38 +0000
From: Thomas Caswell <tcaswell at gmail.com>
To: "Slavin, Jonathan" <jslavin at cfa.harvard.edu>
Cc: Matplotlib-users <matplotlib-users at python.org>
Subject: Re: [Matplotlib-users] backend for matplotlib on NAS Lou
Message-ID:
        <CAA48SF98Gm1Ah02yePh8u_RKW1E9p-1tYqttt-MGO0qnQkJpmQ@
mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

This should go either to anaconda support or to your local sysadmins.

It may also be worth trying to us `tkagg` which tends to bundled with
python and may have a higher chance of working.

Tom

On Mon, Feb 5, 2018 at 11:19 AM Slavin, Jonathan <jslavin at cfa.harvard.edu> > wrote:

> The platform is Suse Linux Enterprise Server 12.
> Also, I checked and there are no modules loaded:
> > module list
> No Modulefiles Currently Loaded.
>
> I also checked that I was launching the anaconda version of
python/ipython.
>
> ?To be more explicit about the error, if I use in my matplotlibrc:
> ?backend : Qt5Agg
> backend.qt4 : PyQt4
>
> Then when I start up ipython with the --pylab argument, I get:
> [TerminalIPythonApp] WARNING | Eventloop or matplotlib integration
failed.
> Is matplotlib installed?
> ------------------------------------------------------------
---------------
> ImportError Traceback (most recent call
last)
> /u/jdslavin/anaconda2/lib/python2.7/site-packages/
IPython/core/shellapp.pyc
> in <lambda>(key)
> 196 shell = self.shell
> 197 if self.pylab:
> --> 198 enable = lambda key: shell.enable_pylab(key,
> import_all=self.pylab_import_all)
> 199 key = self.pylab
> 200 elif self.matplotlib:
> ...
> (snipped)
>
> /u/jdslavin/anaconda2/lib/python2.7/site-packages/
matplotlib/backends/qt_compat.py
> in <module>()
> 135 if QT_API == QT_API_PYQT5:
> 136 try:
> --> 137 from PyQt5 import QtCore, QtGui, QtWidgets
> 138 _getSaveFileName =
> QtWidgets.QFileDialog.getSaveFileName
> 139 except ImportError:
>
> ImportError: /lib64/libpthread.so.0: version `GLIBC_2.12' not found
> (required by
> /u/jdslavin/anaconda2/lib/python2.7/site-packages/PyQt5/
../../.././libglib-2.0.so.0)
>
> So I'm guessing that this has to do with the version of glibc installed
> rather than the missing gui toolkits as I had previously thought. It
could
> be that loading some module might fix the problem, though I'm not sure if
> that's true or which one I'd need to load.
> Any ideas?
>
> Jon

--
________________________________________________________
Jonathan D. Slavin Harvard-Smithsonian CfA
jslavin at cfa.harvard.edu 60 Garden Street, MS 83
phone: (617) 496-7981 Cambridge, MA 02138-1516
cell: (781) 363-0035 USA
________________________________________________________
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-users/attachments/20180208/d09779e3/attachment.html>