backend_agg attribute error

Hi list members

I have been trying to upgrade my Python version to 2.4 from 2.3. With that I removed numarray and Numeric and installed numpy. My Matplotlib, Scipy and wxPython was also upgraded to comply with Python 2.4. In the process I encountered a few problems and all but one I managed to overcome by using CVS versions of Matplotlib.

With the last problem I am bit clueless. I use Boa Cocstructor to write the application that I am busy with and for embedded plotting I am using wxmpl (although Ken McIver said that it has not been tested for Python 2.4). After I run the application and try to plot, nothing shows except the crosshair when I move accross the area where the axes is suppose to be and Boa returns the following error message:

Traceback (most recent call last):

File “C:\Program Files\Python24\Lib\site-packages\”, line 1067, in _onPaint

FigureCanvasWxAgg._onPaint(self, evt)

File “C:\Program Files\Python24\lib\site-packages\matplotlib\backends\”, line 1048, in _onPaint


File “C:\Program Files\Python24\Lib\site-packages\”, line 1124, in draw

FigureCanvasWxAgg.draw(self, repaint)

File “C:\Program Files\Python24\lib\site-packages\matplotlib\backends\”, line 60, in draw


File “C:\Program Files\Python24\lib\site-packages\matplotlib\backends\”, line 385, in draw

renderer = self.get_renderer()

File “C:\Program Files\Python24\lib\site-packages\matplotlib\backends\”, line 396, in get_renderer

self.renderer = RendererAgg(w, h, self.figure.dpi)

File “C:\Program Files\Python24\lib\site-packages\matplotlib\backends\”, line 124, in init

self.draw_quad_mesh = self._renderer.draw_quad_mesh

AttributeError: draw_quad_mesh

Any suggestions? I did get some similar problems when I tried to run the embedded examples, and that I downloaded with my previous Matplotlib version.


Johann Strauss

File "C:\Program
line 124, in __init__

self.draw_quad_mesh = self._renderer.draw_quad_mesh

AttributeError: draw_quad_mesh

This was added to the agg (which affects wxagg) backend between 0.86.1
and 0.86.2. This error is probably not coming from wxmpl/boa. See if
you can run the examples/ which uses this new
functionality, after reinstalling the latest mpl.