zorder not working for grid lines??...

If I'm not mistaken, zorder determines what objects will be

    > "on top" of what other objects.

    > I got this working fine for some lines on my plot but it
    > seems to have no effect on **grid lines**. (I want grid
    > lines to be *behind* everything.)

gridlines are part of the Axis, and do not obey the zorder. But you
can put them above or below by setting the axisbelow property of the