wxmsw26uh_vc.dll and matplotlib 0.87

Hello Charlie,

I tried the solution you suggested below to get py2exe working and get rid of
the "no such file wxmsw26uh_vc.dll" message when trying to run the compiled .exe

1. I removed the _wxagg.pyd file from matplotlib/backends (although I was loathe
to do so as my guess is that this will make plotting slower?)
2. I removed the exclusion on the wxmsw26uh_vc.dll in the setup file

Now I can compile to an .exe but the application starts briefly, but stops and
closes the output window before I can see anything. It doesn't write anything to
the .log file.

I'm running XP, Python 2.4, wxPython and MPL 87.5

Has anybody else tried this solution and got it to work?

Thanks for any help you can provide.

- Daniel

P.S. If it's relevant, my setup.py is below...

# For py2exe only

    Create .exe for VizTool. This code was provided on the Matploblib users
    Run with the following command (use py2exe 0.6.2 or higher)

    python.exe -OO setup.py py2exe -b 3 -c -p numarray,pytz -e numpy


import os
from distutils.core import setup
import py2exe
import glob

import matplotlib

#Following ops assignment pulled from Py2Exe WIKI :
opts = {
    'py2exe': { 'compressed': 1,
                'optimize': 2,
                'packages': ['encodings',
                'includes': 'matplotlib.numerix.random_array',
                'excludes': ['_gtkagg', '_tkagg'],
                'dll_excludes': ['libgdk-win32-2.0-0.dll',

setup( version = '0.0.1',
       windows = ['VizToolApp.py'],
       data_files = [('conf',['conf/GraphStyles.ini']),