Using Windows Binary to install MatPlotLib in different site-packages folder

Careful, "reply" doesn't send your note to the list.

I just looked on the MPl download page in source forge. It looks like there are binary eggs there for Windows. You should be able to install those in your virtualenv and have it all just work. Just make sure you use the right copy of easy_install

-Chris

R. Haynie wrote:

···

Christopher Barker wrote:

R. Haynie wrote:
  

I am using VirtualEnv to have multiple virtual environments that have
their own site-packages folder. So each environment is its own sandbox.
    

another reason why core python really needs to have an "official" versioning system - either something like virtualenv, or (my preference), package versioning built in.

Anyway, in the mean time, two ideas to try:

1) "easxy_install matplotlib" run with the easy_install in your virtual env -- hopefully, it will install a binary Windows egg -- does one exist?

Tried this towards the end of 2008 a few times, did not fair well at all
in Windows.

2) try manually moving the matplotlib package from the system site-packages to your virtualenv.

Ok, this is what I tried today:
  

Uninstalled any python package I had installed with a windows installer,
uninstalled all of python, and cleared the cache folder, deleted
python25 folder.
Installed python 2.5 with windows installer.
Took note of what was in site-packages.
Ran NumPy windows installer, and moved all new files and folders out of
Site-Packages. Moved them to a folder I named c:\site-packages_NumPy.
Did the same for MatPlotLib windows installer. Moved them to a folder I
named c:\site-packages_MatPlotLib.
Got real anal here and uninstalled numpy and matplotlib using the
windows uninstallers. Then uninstalled Python and cleared the cache
folder and deleted python25.

Now this is where I thought I could go and make some nice virtual
environments and have some safe sandboxes. But of course not.
Installed python, easy_install, virtualenv, pywin32.
Created new virtual environment and activated it. Copied the files from
the numpy and matplotlib site-packages folders into the new virtual
environment site-packages folder.
Tryed a simple plot, and got an error that pylab module did not exist.
So, I figured that the windows installers did more than met the eye. They probably install some DLLs etc.
I then installed numpy and matplotlib using the windows installers.
Tried my plot test from within the virtual environment and it worked.

I created a new virtual environment, installed nothing, tried the plot
test from within that environment and the test worked. It should not
have worked.

Looks like I can only have 1 numpy and 1 matplotlib on a windows box at
a time, virtual environments or not.

Let us know how it works out...

I sure hope someone reads this and finds something glaringly wrong with
my process.

--
Christopher Barker, Ph.D.
Oceanographer

Emergency Response Division
NOAA/NOS/OR&R (206) 526-6959 voice
7600 Sand Point Way NE (206) 526-6329 fax
Seattle, WA 98115 (206) 526-6317 main reception

Chris.Barker@...259...