I am using the Navigation toolbars mode and I wonder if I should the attribute or if it can change in a future release ?
The attribute I am talking about is defined in backend_bases.py in NavigationToolbar2 in the __init__() method:
self.mode = '' # a mode string for the status bar
The strings saved on the panning and zoom mode are kinda unconventional:
self.mode = 'pan/zoom mode'
self.mode = 'Zoom to rect mode'
Having the zoom word in both strings can be confusing, moreover they should start either with a lower case or upper case.
Can't they just be "zoom" or "pan" ?
Having just one word as a mode will remove confusion and make them easier to test when you are adding modes to the toolbar ...
Just a suggestion.