usetex=True and savefig(eps-file)

Matthias Michler <MatthiasMichler@...361...> writes:

Do you know why is happens only for ps/eps-files?

The ps backend uses TeX in a different way than the other backends. It
uses psfrag and dvips to construct the final file.

Have you set any TeX-related environment variables or edited any
configuration files? What does "kpsepath tex" print?

in my .zshrc I set
TEXINPUTS=~/Texte/Styles//:.//:

It's probably the .// entry, which causes TeX to search all
subdirectories of the current directory. The ps backend does something
like

cd /tmp && latex file.tex

so it should just look in subdirectories of the temporary directory, but
perhaps it somehow goes awry. Do you have some setting that causes
temporary files to end up in the root directory?

···

--
Jouni K. Seppänen
http://www.iki.fi/jks

Hi Jouni,

thanks again for your advice.

I don't think that I do have 'some setting that causes temporary files to end
up in the root directory", because my system is more or less kubuntu (8.04)
out of the box.

But maybe you are nevertheless right, because in tmp there are ./root
and ./lost+found, which I am not allowed to enter.
Finally this error is due to the behaviour of ps-backend and my TEX-path,
which searches in all sub-directories.

Thanks a lot for your time and advice to locate the root of the strange
behaviour.

Kind regards,
Matthias

···

On Thursday 03 December 2009 19:04:55 Jouni K. Seppänen wrote:

Matthias Michler <MatthiasMichler@...361...> writes:
> Do you know why is happens only for ps/eps-files?

The ps backend uses TeX in a different way than the other backends. It
uses psfrag and dvips to construct the final file.

>> Have you set any TeX-related environment variables or edited any
>> configuration files? What does "kpsepath tex" print?
>
> in my .zshrc I set
> TEXINPUTS=~/Texte/Styles//:.//:

It's probably the .// entry, which causes TeX to search all
subdirectories of the current directory. The ps backend does something
like

cd /tmp && latex file.tex

so it should just look in subdirectories of the temporary directory, but
perhaps it somehow goes awry. Do you have some setting that causes
temporary files to end up in the root directory?