Upgrading matplotlib

Hi all,
I have an issue in upgrading my matplotlib 1.0.1 to 1.3.1

I am using Fedora, but the command:

Yum update python-matplotlib is not working.

My python version is 2.7, is that an issue?

Is there any way for upgrading matplotlib?

Regards,

Rachana K

Hi all,
I have an issue in upgrading my matplotlib 1.0.1 to 1.3.1
I am using Fedora, but the command:
Yum update python-matplotlib is not working.
My python version is 2.7, is that an issue?
Is there any way for upgrading matplotlib?

Updating via a linux distro generally won't bring you a new version.

Two options:

1) Install it yourself independently, typically in /usr/local/, compiling from source. This will involve making sure you have some build dependencies. Simply using "pip install matplotlib", or something very much like that, might work.

2) Get an entire independent python installation such as Anaconda from continuum.io. This provides an easy way of keeping everything up to date. This is what I recommend unless you really want to learn how to build and install software yourself, independently of installers like yum.

Eric

ยทยทยท

On 2014/06/12, 4:14 AM, Rachana Katkam wrote:

Regards,
Rachana K

------------------------------------------------------------------------------
HPCC Systems Open Source Big Data Platform from LexisNexis Risk Solutions
Find What Matters Most in Your Big Data with HPCC Systems
Open Source. Fast. Scalable. Simple. Ideal for Dirty Data.
Leverages Graph Analysis for Fast Processing & Easy Data Exploration
http://p.sf.net/sfu/hpccsystems

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users