upgrade problems

I am having problems plotting anything using version 0.98.1 on Linux
Debian 4. But 0.91.4 works fine.

When I try to plot something I get this error on the console:

Traceback (most recent call
last):

File
“/usr/lib/python2.4/site-packages/matplotlib/backends/backend_gtk.py”,
line 331, in expose_event

self._render_figure(self._pixmap, w, h)

File
“/usr/lib/python2.4/site-packages/matplotlib/backends/backend_gtkagg.py”,
line 75, in _render_figure

FigureCanvasAgg.draw(self)

File
“/usr/lib/python2.4/site-packages/matplotlib/backends/backend_agg.py”,
line 357, in draw

self.renderer

= self.get_renderer()

File
“/usr/lib/python2.4/site-packages/matplotlib/backends/backend_agg.py”,
line 368, in get_renderer

self.renderer = RendererAgg(w, h, self.figure.dpi)

File
“/usr/lib/python2.4/site-packages/matplotlib/backends/backend_agg.py”,
line 116, in init

self.draw_polygon = self._renderer.draw_polygon

AttributeError: draw_polygon

And here is the configuration info from when I installed from src:

BUILDING MATPLOTLIB

matplotlib: 0.98.1

python: 2.4.4 (#2, Apr 15 2008, 23:43:20) [GCC 4.1.2

20061115 (prerelease) (Debian 4.1.1-21)]

platform: linux2

REQUIRED DEPENDENCIES

numpy: 1.1.0

freetype2: 9.10.3

OPTIONAL BACKEND
DEPENDENCIES

libpng: 1.2.15beta5

Tkinter: Tkinter: 39220, Tk: 8.4, Tcl: 8.4

wxPython: 2.8.8.1

  • WxAgg extension not required for wxPython >= 2.8

Gtk+: gtk+: 2.8.20, glib: 2.12.4, pygtk: 2.8.6, pygobject:

[pre-pygobject]

Qt: Qt: 3.3.6, PyQt: 3.16

Qt4: no

Cairo: 1.2.0

OPTIONAL DATE/TIMEZONE
DEPENDENCIES

datetime: present, version unknown

dateutil: present, version unknown

pytz: 2006p

OPTIONAL USETEX DEPENDENCIES

dvipng: 1.9

ghostscript: 8.15.3

latex: 3.141592

pdftops: 3.00

EXPERIMENTAL CONFIG PACKAGE
DEPENDENCIES

configobj: matplotlib will provide

enthought.traits: no

I am guessing that I am either missing a library or need an updated
version. Does anyone have any ideas?

Thanks,

-Ben

Ben Axelrod wrote:

I am having problems plotting anything using version 0.98.1 on Linux Debian 4. But 0.91.4 works fine.

If you are compiling from source, the problem could be that setup.py does not clean out the destination directory. For example, if you are installing in /usr/local/lib/python2.5/site-packages then you should first do "rm -r /usr/local/lib/python2.5/site-packages/matplotlib*" before installing another version.

Eric

···

When I try to plot something I get this error on the console:

Traceback (most recent call last):

  File "/usr/lib/python2.4/site-packages/matplotlib/backends/backend_gtk.py", line 331, in expose_event

    self._render_figure(self._pixmap, w, h)

  File "/usr/lib/python2.4/site-packages/matplotlib/backends/backend_gtkagg.py", line 75, in _render_figure

    FigureCanvasAgg.draw(self)

  File "/usr/lib/python2.4/site-packages/matplotlib/backends/backend_agg.py", line 357, in draw

    self.renderer = self.get_renderer()

  File "/usr/lib/python2.4/site-packages/matplotlib/backends/backend_agg.py", line 368, in get_renderer

    self.renderer = RendererAgg(w, h, self.figure.dpi)

  File "/usr/lib/python2.4/site-packages/matplotlib/backends/backend_agg.py", line 116, in __init__

    self.draw_polygon = self._renderer.draw_polygon

AttributeError: draw_polygon

And here is the configuration info from when I installed from src:

BUILDING MATPLOTLIB

            matplotlib: 0.98.1

                python: 2.4.4 (#2, Apr 15 2008, 23:43:20) [GCC 4.1.2

                        20061115 (prerelease) (Debian 4.1.1-21)]

              platform: linux2

REQUIRED DEPENDENCIES

                 numpy: 1.1.0

             freetype2: 9.10.3

OPTIONAL BACKEND DEPENDENCIES

                libpng: 1.2.15beta5

               Tkinter: Tkinter: 39220, Tk: 8.4, Tcl: 8.4

              wxPython: 2.8.8.1

                        * WxAgg extension not required for wxPython >= 2.8

                  Gtk+: gtk+: 2.8.20, glib: 2.12.4, pygtk: 2.8.6, pygobject:

                        [pre-pygobject]

                    Qt: Qt: 3.3.6, PyQt: 3.16

                   Qt4: no

                 Cairo: 1.2.0

OPTIONAL DATE/TIMEZONE DEPENDENCIES

              datetime: present, version unknown

              dateutil: present, version unknown

                  pytz: 2006p

OPTIONAL USETEX DEPENDENCIES

                dvipng: 1.9

           ghostscript: 8.15.3

                 latex: 3.141592

               pdftops: 3.00

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES

             configobj: matplotlib will provide

      enthought.traits: no

I am guessing that I am either missing a library or need an updated version. Does anyone have any ideas?

Thanks,

-Ben

------------------------------------------------------------------------

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/

------------------------------------------------------------------------

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users