trunk rev 8843 crash on Snow Leopard

In article

> I built a binary installer for matplotlib trunk rev 8843 (because it
> leaks memory less than 1.0.0 release). I built it the same way I built
> the 1.0.0 binary
> <
> > on Mac OS X 10.4 using Python 2.6.x (where x is probably
> 6).
> The binary is available here:
> <
> wen/python/>
> >
> It work fine on Mac OS X 10.4 and 10.5, but on 10.6 attempting to import
> pylab almost always segfaults (and the few times I've gotten it to work
> on 10.6 I can break it by deleting ~/.fontconfig and ~/.matplotlib and
> running Python again). I've tried it on newly created accounts and it
> segfaults. Another user of Snow Leopard first reported the problem. So
> it's not just me.
> I've appended part of a crash log.
> I built this binary the same way I built the matplotlib 1.0.0 binary,
> which has no problems.

Could you try a "divide and conquer" approach to narrow down which svn
revision introduced the breakage. I realize this is tedious, especially
since the bug manifestation is variable, but it if we could figure out the
revision number, we'd be more likely to be able to fix it.

Good suggestion. I tried remaking the an installer for 1.0.0 and it has
the exact same issue. I am surprised because I only use the machine for
one purpose: making binary installers) and I don't recall rebuilding any
of the libraries but either I did or there's been some corruption.

In any case the good news is that it has nothing to do with matplotlib
itself and is all my fault. Presumably libfreetype has gotten corrupted
or I built a new version and messed something up. I'll pursue it.


-- Russell


John Hunter <jdh2358@...149...> wrote:

On Mon, Dec 20, 2010 at 6:31 PM, Russell E. Owen > <rowen@...748...> wrote: