trouble installing new matplotlib on mac os x

hi all,

i am trying to install matplotlib-0.99 on a mac os x machine, with the
following python:

Python 2.5.1 (r251:54863, Jan 13 2009, 10:26:13)
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin

using version 10.5.6 of mac os x. when i go to
http://sourceforge.net/projects/matplotlib/ it prompts me to download
matplotlib-0.99.0-py2.5-macosx10.5.dmg. when i download this
installer and install it, it only lets me to install it in my mac
harddrive (I don't see any option to change the installation
location.) installation goes through smoothly and in the end i get
the "installation successful" message. however, only the older
version of matplotlib comes up when i do "import matplotlib". i also
cannot where the new version was installed. does anyone know where the
files for the new matplotlib should be? they are not in
/Library/Frameworks/Python2.5/ it seems.

if i do:

locate matplotlib | grep 0.99

nothing comes up. i only see files related to the older matplotlib
when i do "locate matplotlib" in the shell.
any ideas how i can install this? i wanted to try the .egg
installation with "easy_install" but when i do:

easy_install matplotlib

it matches to a 0.98 version of matplotlib, not 0.99.

thanks for your help