strangely shifted PostScript output when

As a workaround, can you just turn the axis box and ticks off?

xticks([])
yticks([])
setp(ax,‘frame_on’,False)

Or does that give the same problem?

Hi Mark,

As a workaround, can you just turn the axis box and ticks off?

xticks([])
yticks([])
setp(ax,'frame_on',False)

Or does that give the same problem?

Unfortunately the problem also occurs when I replace the axis("off")
with the lines suggested by you. The xticks commands work, but the
setp breaks things again:

with setp (broken output):

    voss@...1897... [~/project/kalman/survey/fig2] grep -i BoundingBox out.eps
    %%BoundingBox: 1 300 326 417
    %%HiResBoundingBox: 1.923182 300.843797 325.923182 416.043797

without setp (output looks ok but has an extra frame):

    voss@...1897... [~/project/kalman/survey/fig2] grep -i BoundingBox out.eps
    %%BoundingBox: 143 338 468 454
    %%HiResBoundingBox: 143.999991 338.520012 467.999991 453.720012

Is there anything else I can try?

Many thanks,
Jochen

···

On Tue, Feb 26, 2008 at 11:30:55AM +0100, Mark Bakker wrote:
--
http://seehuhn.de/

To me it sounds like the bounding box is miscalculated when the axis are turned off.
What you could do as a workaround, is add a fill to the figure that has the exact same size as the axis box. Maybe then, when you turn the axis off it will keep the same size? May be an ugly workaround, but worth a shot. You also don’t have to set the backgroundcolor of your plot anymore.
Mark

···

On Tue, Feb 26, 2008 at 3:22 PM, Jochen Voss <lists@…384…> wrote:

Hi Mark,

On Tue, Feb 26, 2008 at 11:30:55AM +0100, Mark Bakker wrote:

As a workaround, can you just turn the axis box and ticks off?

xticks([])

yticks([])

setp(ax,‘frame_on’,False)

Or does that give the same problem?

Unfortunately the problem also occurs when I replace the axis(“off”)

with the lines suggested by you. The xticks commands work, but the

setp breaks things again:

with setp (broken output):

voss@...1897... [~/project/kalman/survey/fig2] grep -i BoundingBox out.eps

%%BoundingBox: 1 300 326 417

%%HiResBoundingBox: 1.923182 300.843797 325.923182 416.043797

without setp (output looks ok but has an extra frame):

voss@...1897... [~/project/kalman/survey/fig2] grep -i BoundingBox out.eps

%%BoundingBox: 143 338 468 454

%%HiResBoundingBox: 143.999991 338.520012 467.999991 453.720012

Is there anything else I can try?

Many thanks,

Jochen

http://seehuhn.de/

-----BEGIN PGP SIGNATURE-----

Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHxCC7f+iD8yEbECURAlbHAKCtb0KbmVSQJV3upSGfwp5ytP4J0gCfRKQm

QvynbyKTxvsKQuAiy5EWyOI=

=Wx7H

-----END PGP SIGNATURE-----