strange contour plot

This is caused by an interaction between antialiasing and filled areas with perfectly aligned edges. Both Agg and Cairo suffer from this "problem". There has been a discussion on the devel a few times about ways around it, none of which have really panned out, if I recall correctly. Though this isn't a regression, as far as I can tell. 0.98.5.x produces the same lines as SVN (at least for me).

Sorry I don't have an easy answer to this.

Mike

Jeffrey Fogel wrote:

···

Last question, I promise. The new contourf seems to include faint lines for the contours. I would like to remove these, but the docstring doesn't seem to have a kwarg to do so. Do you know how to remove them?

-Jeffrey

On Thu, Jul 16, 2009 at 2:01 PM, Jeffrey Fogel > <matplotlib@…2127… <mailto:matplotlib@…2127…>> wrote:

    nevermind, I just re-ran the setup.py script and now it's
    working. Strange, but oh well. The contour plot is also working
    now. Thanks for all your help with this.

    -Jeffrey

    On Thu, Jul 16, 2009 at 1:55 PM, Jeffrey Fogel > <matplotlib@…2127… <mailto:matplotlib@…2127…>> > wrote:

        Quick question. I thought the compiling from source went
        smoothly, but when I try "from pylab import *" I get the
        following error:

        /Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/matplotlib/dates.py
        in <module>()
             85 import re, time, math, datetime
             86
        ---> 87 import pytz
             88
             89 # compatability for 2008c and older versions

        ImportError: No module named pytz

        Do you have any idea why? I thought pytz was supposed to be
        included in matplotlib (that's what the setup.py script seems
        to imply). I'm running OS X 10.4.11. Thanks.

        -Jeffrey

        On Thu, Jul 16, 2009 at 1:15 PM, Jeffrey Fogel > <matplotlib@…2127… > <mailto:matplotlib@…2127…>> wrote:

            Thanks for looking into it and glad to hear that it was
            fixed. Depending on whether this shows up for the plots
            I'm making for the paper I'm writing, I may hold off on
            compiling from source until the paper is done. Were there
            any other major changes/problems in the svn version?

            -Jeffrey

            On Thu, Jul 16, 2009 at 12:20 PM, Michael Droettboom > <mdroe@…86… <mailto:mdroe@…86…>> wrote:

                It looks like this bug has been fixed on the SVN
                trunk. Unfortunately, these changes were pretty major
                surgery, so they don't easily apply to 0.98.5.x.
                 Unfortunately, for the time being, it looks like
                you'll need to wait until the next release, or compile
                matplotlib from SVN yourself. I haven't heard any
                concrete plans about the next release yet.

                Cheers,
                Mike

                Jeffrey Fogel wrote:

                    I haven't tried that as I didn't realize there was
                    an issue there. I'm fairly new to matplotlib and
                    am definitely still learning how to use it.
                     Thanks for your help with this, I've attached 3
                    data files and the test script. Please let me
                    know what you find (and feel free to comment on
                    the code if there is an easier way to do something).
                    -Jeffrey

                    On Thu, Jul 16, 2009 at 12:00 PM, Michael > Droettboom <mdroe@…86… > <mailto:mdroe@…86…> <mailto:mdroe@…86… > <mailto:mdroe@…86…>>> wrote:

                       You might be running into one of the path
                    simplification bugs in
                       the 0.98.x series. Have you tried with the
                    rcParam path.simplify
                       turned off? If you can sent me a self
                    contained script and data
                       off-list, I can test this against the SVN
                    version to see if this
                       has already been addressed.

                       Cheers,
                       Mike

                       Jeffrey Fogel wrote:

                           I'm having a strange problem with my
                    contour plots and I'm
                           hoping someone here will be able to help.
                     I had a dataset
                           that was plotting fine until I decided I
                    wanted to create
                           plots with the data mirrored over the
                    x-axis. This seems to
                           work fine most of the time, but every now
                    and then I get a
                           plot that seems to just ignore a couple of
                    data points when
                           creating the contours. I've attached a
                    plot of what I mean.
                            Looking at the arrays the contour plot is
                    created from
                           doesn't show any obvious problems (there
                    are values there that
                           should be plotted). It's very strange, any
                    ideas?

                           matplotlib 0.98.5.2
                           numpy 1.2.1
                           python 2.5.1

                           -Jeffrey
                                              ------------------------------------------------------------------------

                                              ------------------------------------------------------------------------

                                              ------------------------------------------------------------------------------
                           Enter the BlackBerry Developer Challenge
                     This is your chance
                           to win up to $100,000 in prizes! For a
                    limited time, vendors
                           submitting new applications to BlackBerry
                    App World(TM) will have
                           the opportunity to enter the BlackBerry
                    Developer Challenge.
                           See full prize details at:
                    http://p.sf.net/sfu/Challenge
                                              ------------------------------------------------------------------------

                           _______________________________________________
                           Matplotlib-users mailing list
                           Matplotlib-users@lists.sourceforge.net
                    <mailto:Matplotlib-users@lists.sourceforge.net>
                                              <mailto:Matplotlib-users@lists.sourceforge.net
                    <mailto:Matplotlib-users@lists.sourceforge.net>>

                                              https://lists.sourceforge.net/lists/listinfo/matplotlib-users
                           
                       -- Michael Droettboom
                       Science Software Branch
                       Operations and Engineering Division
                       Space Telescope Science Institute
                       Operated by AURA for NASA

                -- Michael Droettboom
                Science Software Branch
                Operations and Engineering Division
                Space Telescope Science Institute
                Operated by AURA for NASA

--
Michael Droettboom
Science Software Branch
Operations and Engineering Division
Space Telescope Science Institute
Operated by AURA for NASA