Report to matplotlib-devel: problem installing matplotlib on Mac OS X - traced to missing dependency (workaround enclosed)

Message for matplotlib developers

I have posted a message on the matplotlib-users list, but it may be of interest to some in the -devel list as well. Here is an excerpt describing an installation problem, and workaround, that affects Mac OS X and matplotlib.

I am new to Python, and have tried installing matplotlib on a Mac OS X 10.6 (Snow Leopard). In spite of excellent tools and documentation provided, the installation was unsuccessful:
- my computer is 10.6.6 (fully updated Snow Leopard)
- with full Xcode (c developers) code installed
- it reports Python 2.6.1 installed
- it installs packages such as numpy and biopython ok (which gives me a little confidence that I am doing things correctly)

But when I tried to install matplotlib 1.0.1, I encountered the following problems:
- the matplotlib mkpg .dmg files will not run as they advise Python 2.6 is required (but which is already installed!)
- upgrading to Python 2.7 did not fix this problem and the error message continued
- using tar and then installing via Python install files resulted in an unsatisfied compiler reference from "lipo"
- installing Python easy-install and using .egg scripts produced the same error message

A call for help on the matplotlib-users list produced a suggestion to go back to matplotlib 1.0.0 (not 1.0.1). This worked on one Mac, but did not work on a second Mac (with what I thought was identical configuration).
Finally, a general solution was found using MacPorts, as follows:

**update** matplotlib 1.0.0 setup worked on one but did not work on a second Mac OS X 10.6.6. The second one again failed with a missing dependency. It seems to depend on what previous packages may have been installed.
The following seems to be a complete fix:
1. On Mac OS X 10.6.x (in my case...6)
2. Install Apple Xcode (requires registration as an Apple developer)
3. Install MacPorts http://www.macports.org/
4. Check that all library dependencies for matplotlib in Python 2.6 have been satisfied by first running (with Administrator privileges):
  sudo port install py26-matplotlib
(this will use MacPorts script to install matplotlib 1.0.0)
5. (optional) you can reinstall now matplotlib from http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-1.0/matplotlib-1.0.0.tar.gz/download
**now** it works :slight_smile:

The above may suggest that matplotlib may have a dependency that is not present on a virgin OSX Xcode machine but which is incidentally installed by some other package usually present on a developer's machine and so whose absence is not noticed when preparing the installation script.

I hope the above report is of assistance to the devel community. I am a newbie to this so won't be of much help to you other than having found and documented the problem.

Many thanks for bringing matplotlib to the world!

Leslie Burnett
Sydney University