Apparently I was misusing the list by having digests sent – apologies.
I have turned this off.
Maybe the following got lost in the resulting noise:
I completely agree that the current defaults need updating.
In my opinion, ‘rcParams’ is a bad name, since it conjures up dusty configuration files hidden in obscure corners which must never be modified.
Indeed, http://en.wikipedia.org/wiki/Run_commands says that the origin of ‘rc’ is:
The term rc stands for the phrase “run commands”. It is used for any file that contains
startup information for a command. It is believed to have originated somewhere in 1965
None of these three ‘features’ of the phrase ‘rc’ have anything to do with matplotlib.
‘rc’ evokes fond memories of hacking for a few; it evokes nothing and reeks of alienating hack-speak to the rest.
I thus suggest that we replace rc_Params -> mpl_params.
As an example, I have made some narrative documentation, which can be included in the matplotlib documentation (let’s discuss where, Nelle and Mike), on how to tweak mpl_params:
This is, if you like, a cosmetic change, but I think it’s an important psychological one.
It also avoids the visual interruption caused by the capital ‘P’.
Of course, anybody is free to make this change in the way I have in the notebook by creating an alias, mpl_params = rcParams. But I am advocating for changing uniformly to mpl_params (or a similar phrase) in the documentation.
Dr. David P. Sanders
Profesor Titular “A” / Associate Professor
Departamento de Física, Facultad de Ciencias
Universidad Nacional Autónoma de México (UNAM)
Cubículo / office: #414, 4o. piso del Depto. de Física
Tel.: +52 55 5622 4965