Quest to resolve the Import error

Trying to resolve MatplotLib related error on Anaconda

Hello Friends,

I have been trying to resolve the MatplotLib’s Module NotFound Error

While researching I found a prospective solution, uninstalled & installed matplotlib.

After trying this I stumbled on another issue “Error parsing requirements for pandas”:

I tried to ignore the warning and tried importing matplotlib on Jupyter Notebook, though this time I was getting Attribute Error: module ‘matplotlib’ has no attribute ‘rcParams’
Please note that I am using Windows OS and my current versions are:

conda : 4.9.2, Python: 3.7.9, matplotlib: 3.2.2 & matplotlib-base: 3.3.4

I am guessing that there is a difference in the versions of the matplotlib and the matplotlib-base could be the cause of error, so tried finding the difference between the two and I found this:

At this point, I am confused and I want to resolve this so that I can leverage Anaconda & Jupyter. I have been working on Google Colab for work assignments in the past weeks.

I would appreciate it if you share your experiences if you encountered and resolved a similar issue or if you know of a prospective solution then please let me know.

Looking forward to hearing from you.



This really sounds like you have a file named somewhere in your path. Start with a fresh environment in an empty directory and see if the issue persists.