python crash

win32, xp, python 2.3.3 matplotlib: __version__ = '0.60.2'

    > __revision__ = '$Revision: 1.64 $'

    > Any attempt to save ps: savefig('fig.ps')

    > gives this:

    > Fatal Python error: PyEval_RestoreThread: NULL tstate

    > This application has requested the Runtime to terminate it
    > in an unusual way. Please contact the application's
    > support team for more information.

    > The postscript file *is* actually written.

    > What more info do you need to track this?

Bizarre - on virtually the same platform (windows xp, 0.60.2,
enthought python 2.3.3) I can save PS either directly

  > python simple_plot.py -dPS

or from the GUI by clicking save and using a ps or eps extension with
no troubles, warnings or errors.

As for more information: how are you running matplotlib when you try
to save ps (ie from a GUI window, from an IDE, by setting ps as the
backend in rc, interactively from the python shell)? Do you still get
the same error when calling a script from the command shell with -dPS
as above? Which matplotlib windows installer are you using:

  matplotlib-0.60.2-numarray0.9-win32-py2.3.exe
  matplotlib-0.60.2-numarray1.0-win32-py2.3.exe
  matplotlib-0.60.2.win32-py2.3.exe?

What is your numerix setting in
c:\python23\share\matplotlib\.matplotlibrc, or wherever you keep your
rc file? Do you get this problem when you try to save png with the
agg backend?

After gathering the info above, I suggest removing
c:\python23\lib\site-packages\matplotlib and
c:\python23\share\matplotlib and doing a clean install.

From your message (PyEval_RestoreThread: NULL), I'm guessing you are
running from an IDE (idle?) with the tkagg backend and are getting a
mainloop conflict. Have you read
http://matplotlib.sourceforge.net/faq.html#FREEZE?

Good luck! JDH