pylab import problems

Just installed FC6 onto AMD 64 bit processor and have

    > installed Python. I have also installed numpy and
    > matplotlib however when I run IPython and begin importing
    > items I run into a problem when try to import pylab.
    > Specifically I receive the following dump:

    > ImportError: No module named _ns_backend_gdk

Or a 2nd thought -- it may be that pygtk or the gtk-devel environment
was not in place when you built. Even if they are installed,
matplotlib requires a connection to the X11 server when building the
gtk backend, something that is not always available when building as


  1) make sure you have the proper numpy installed, as in my previous

  2) make sure you can do

     >>> import gtk

     in the same environment in which you are building and installing

   3) make sure you have the gtk-devel headers and libs installed, as
      well as the other devel libs listed on the installing pages of
      the web site.

   4) capture stdout and stderr when you build, and post it if you
      encounter further problems

      > python build >& build.out