problem with saving eps and ps with GTKAgg backend (and current head of SVN)

I am closing the issue I had with ghostscript : I just built in /usr/local ghostscript 8.56 and now saving in eps file does not truncate the figure anymore.
Thanks to Darren for pointing out that the FC5 version of ghostscript is way old.... And it looks like the FC7 version is as old !!
Probably a licensing issue.

Anyway, thanks.
Johann

Darren Dale wrote:

···

On Monday 21 May 2007 10:42:26 am you wrote:
  

hi Darren,
thanks. I am not sure what you have in mind with the GPL.... My
ghostscript rpm are :
[cohen@...142... ~]$ rpm -qa | grep ghostscript
ghostscript-devel-8.15.2-1.1
ghostscript-8.15.2-1.1
ghostscript-fonts-5.50-13.1
ghostscript-gtk-8.15.2-1.1
    
There are three different versions of ghostscript: AFPL, GPL (formerly GNU), and ESP ghostscript. You most likely have ESP ghostscript. Fortunately, I just read that ESP and GPL ghostscript are merging as of version 8.57, and the ESP project will be discontinued.

Given the fact that I use FC5 I would be surprised to be using very old
versions, which then would cause problems.
    
GPL 8.15 was released almost 3 years ago.

I had more in mind configuration probl;ems or mismatch....
    
There have been all kinds of problems reported on this mailing list with usetex that were solved by upgrading ghostscript to 8.54.

I am closing the issue I had with ghostscript : I just built in
/usr/local ghostscript 8.56 and now saving in eps file does not truncate
the figure anymore.

Good news, thanks for the update.

Thanks to Darren for pointing out that the FC5 version of ghostscript is
way old.... And it looks like the FC7 version is as old !!
Probably a licensing issue.

It's not a licensing issue; many linux distributions ship ESP ghostscript
because it supposedly works better with the CUPS printing system. I have been
using GPL ghostscript with CUPS for a long time, with no complaints. But here
is some good news: ESP cups is merging with GPL cups as of version 8.57, and
the ESP project will be discontinued.

···

On Monday 21 May 2007 01:28:27 pm Johann Cohen-Tanugi wrote:

Darren Dale wrote:
> On Monday 21 May 2007 10:42:26 am you wrote:
>> hi Darren,
>> thanks. I am not sure what you have in mind with the GPL.... My
>> ghostscript rpm are :
>> [cohen@...142... ~]$ rpm -qa | grep ghostscript
>> ghostscript-devel-8.15.2-1.1
>> ghostscript-8.15.2-1.1
>> ghostscript-fonts-5.50-13.1
>> ghostscript-gtk-8.15.2-1.1
>
> There are three different versions of ghostscript: AFPL, GPL (formerly
> GNU), and ESP ghostscript. You most likely have ESP ghostscript.
> Fortunately, I just read that ESP and GPL ghostscript are merging as of
> version 8.57, and the ESP project will be discontinued.
>
>> Given the fact that I use FC5 I would be surprised to be using very old
>> versions, which then would cause problems.
>
> GPL 8.15 was released almost 3 years ago.
>
>> I had more in mind
>> configuration probl;ems or mismatch....
>
> There have been all kinds of problems reported on this mailing list with
> usetex that were solved by upgrading ghostscript to 8.54.

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

--
Darren S. Dale, Ph.D.
Staff Scientist
Cornell High Energy Synchrotron Source
Cornell University
275 Wilson Lab
Rt. 366 & Pine Tree Road
Ithaca, NY 14853

dd55@...163...
office: (607) 255-3819
fax: (607) 255-9001
http://www.chess.cornell.edu