problem with matplotlib-0.98.5-py2.5-macosx-10.3.egg

I had the same problem with the matplotlib-0.98.5-py2.5-macosx-10.3.egg on OS X 10.5 and finally determined that it expected the latest png library. The one on the most recent release of the OS is a littler earlier. I compiled the library from the png website and redid the easy_install and everything worked fine.

John M.


-----Original Message-----

Date: Sat, 13 Dec 2008 22:08:37 +0000
From: Robin <robince@...287...>
Subject: Re: [Matplotlib-users] problem with
To: "John Hunter" <jdh2358@...287...>
Content-Type: text/plain; charset=ISO-8859-1

On Sat, Dec 13, 2008 at 9:17 PM, John Hunter <jdh2358@...287...> wrote:

On Sat, Dec 13, 2008 at 3:01 PM, Robin <robince@...287...> wrote:

As in my other mail I am having trouble building from source.
Previously I used the mac .egg to get around this, but the
matplotlib-0.98.5-py2.5-macosx-10.3.egg for 0.98.5 doesn't appear to

I think the egg may be broken. Try grabbing the tarball and following
the instructions at

Right - following these exactly worked (I had been missing out the
pkgconfig bit)