Problem in backporting Matplotlib for Py3 on Kubuntu Precise

Hello. I don't use Matplotlib directly (yet) but I wish to use
https://github.com/scios/IPyXt which needs it, and I'm using IPython
and SymPy both with Python 3. (Current version on my Kubuntu Precise
system is 3.2.3.) So I'm trying to backport v1.2.0 from Kubuntu 13.0x
(http://packages.ubuntu.com/raring/python3-matplotlib). I have all the
build-dependencies (I backported python3-dateutil and python3-tz too
from latest Debian) but when I run dpkg-buildpackage, it terminates
with the errors:

python-dbg: ../Objects/object.c:65: _Py_AddToAllObjects: Assertion
`(op->_ob_prev == ((void *)0)) == (op->_ob_next == ((void *)0))'
failed.
Aborted (core dumped)
make: *** [clean] Error 134
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

The complete runlog is attached. Can anyone please help me out? Thanks.

matplotlib-backport-errors (6.24 KB)

···

--
Shriramana Sharma

If it helps, I have a PPA with builds of the development version of
matplotlib, including Python 3 builds on precise. I use those packages
myself, and it's been pretty stable.

https://code.launchpad.net/~takluyver/+archive/matplotlib-daily

Best wishes,
Thomas

···

On 29 December 2012 13:53, Shriramana Sharma <samjnaa@...149...> wrote:

Hello. I don't use Matplotlib directly (yet) but I wish to use
https://github.com/scios/IPyXt which needs it, and I'm using IPython
and SymPy both with Python 3. (Current version on my Kubuntu Precise
system is 3.2.3.) So I'm trying to backport v1.2.0 from Kubuntu 13.0x
(http://packages.ubuntu.com/raring/python3-matplotlib). I have all the
build-dependencies (I backported python3-dateutil and python3-tz too
from latest Debian) but when I run dpkg-buildpackage, it terminates
with the errors:

Thank you very much -- I should have searched the PPAs myself. Now
have installed.

Just one more question: why is inkscape a build-dep?

···

On Sat, Dec 29, 2012 at 9:24 PM, Thomas Kluyver <thomas@...1071...> wrote:

If it helps, I have a PPA with builds of the development version of
matplotlib, including Python 3 builds on precise. I use those packages
myself, and it's been pretty stable.

https://code.launchpad.net/~takluyver/+archive/matplotlib-daily

--
Shriramana Sharma

If it helps, I have a PPA with builds of the development version of
matplotlib, including Python 3 builds on precise. I use those packages
myself, and it's been pretty stable.

https://code.launchpad.net/~takluyver/+archive/matplotlib-daily

Thank you very much -- I should have searched the PPAs myself. Now
have installed.

Just one more question: why is inkscape a build-dep?

Only because it is used in the tests, to test the svg backend.

Eric

···

On 2012/12/29 6:25 AM, Shriramana Sharma wrote:

On Sat, Dec 29, 2012 at 9:24 PM, Thomas Kluyver <thomas@...1071...> wrote: