Problem generating pdf file with LaTeX fonts

P�l Gunnar Ellingsen <paalge@...287...> writes:

This is very strange I agree. I checked the pdftex.map file and it has
changed due to me upgrading texlive 2011 during a normal fedora update some
days ago. I've checked the log for the update, and the update contained a
new updmap.cfg (which is the script for generating pdftex.map), which
explains the difference in pdftex.map, though it does not help with solving
the problem.

So it might be caused by updmap configuration. Are you able to compile
TeX source files that contain text in cmr12 using pdftex? E.g., put

    \documentclass[12pt]{article}
    \begin{document}
    foo bar
    \end{document}

in foo.tex and try pdflatex foo.tex. If you run into errors, or if the
output file has ugly bitmap Type-3 fonts like TeX-produced pdf files
used to have in the 1990s, it's clearly a bug in your TeX installation.
If not, it's more a problem in dviread's hijacking of pdftex.map for its
own purposes.

(Oh, I see that your problem is already fixed, but maybe future
searchers will benefit from this suggestion.)

http://www.linux.cz/pipermail/texlive/2011-March/000105.html(removing
texlive-amsfonts (without dependencies) and installing it again)
I tried the solution used there, and it worked, meaning that pdftex.map now
contains cmr12 and my test.py file runs properly and gives me a nice pdf
file.

A simpler fix might have been "sudo updmap-sys --enable MixedMap=cm.map".

So again sorry for messing this up. I would like to thank you very much for
your help.

No problem, and good that you got it sorted out!

···

--
Jouni K. Sepp�nen
http://www.iki.fi/jks