problem building on solaris 10

incredibly simple, anyway). After two solid days of

    > commenting this and that out, recompiling everything and its
    > mother 76 different ways from Sunday, poring over a legion
    > of Solaris sys includes, slaughtering a few spotlessly white
    > lambs and one pure black sheep, wrapping the bones and

This information is incredibly helpful -- please do make a wiki entry.

    > There is one remaining item I find extremely puzzling about
    > the whole affair, though. Since I don't have a recent
    > glib/gtk+ library installed, and didn't want to make more
    > hoops for myself to jump through, I attempted to build
    > muhpuhbuh without gtk+ support. Nothing I did would get it
    > to build without gtk+ support, though. I finally commented
    > out every line in setup.py and setupext.py that had anything
    > to with gtk+ (the variables BUILD_GTKAGG, BUILD_GTK, etc.,
    > the conditional code-blocks if BUILD_GTK:, if BUILD_GTKAGG:,

This is totally normal. All the backend_gtk*.py files will be
installed regardless of your setup.py settings. Don't go to any
heroics in that file (eg trying to comment out the build_* funcs as
you did). Just set the advertised flags (eg BUILD_GTKAGG flag). This
will affect what *extension code* gets compiled, but not what python
files get installed.

Your problem is that you failed to heed my somewhat cryptic advice at
the end of my last post, particularly the bit at the end that I
reproduce here

  Another lurking gotcha along these lines is the backend setting.

    backend : GTKAgg # the default backend
    numerix : Numeric # Numeric or numarray

  As with numerix, the backend setting requires you have the
  appropriate GUI toolkit installed (eg pygtk) often at compile time
  if you want to use a GUI. If you are only doing offline image
  production you can make the backend Agg. See also

    http://matplotlib.sf.net/backends.html.

The basic point which I failed to make clear is that the *runtime
configuration* is independent of the *compile time* configuration.
Yes, this is suboptimal but it is. So you need to change the default
backend which is chosen at runtime in your rc file, as described in
http://matplotlib.sf.net/matplotlibrc. Clear?

matplotlib / pylab does a lot of magic under the hood. In the best of
circumstances, it "just works". Obviously based on your experience we
have a ways to go before this mantra actually holds. One way to tease
apart what mpl is doing under the hood is to create a simple test
script like

  from pylab import plot, show
  plot([1,2,3])
  show()

and run it with

  > python myscript --verbose-helpful

This will show you what rc file is being parsed, what backend is set,
what your numerix setting is, and so forth.

Good luck!
JDH