plt.ion() doesn't enable interactive mode when ran as script on mac osx 10.8.5

Using python 2.7.5 and matplotlib 1.4.0 on mac OSX 10.8.5.

The output of the following snippet:

import matplotlib.pyplot as plt
plt.ion()
print "Is interactive:?", plt.isinteractive()

when ran from shell ($ python snippet.py) is:

Is interactive? : 0

i.e. interactive mode does not work.

I think that this is not the expected behaviour. How can this be fixed?

The same code produces

Is interactive? : 1

(i.e. works fine) when ran in an interactive python terminal on the same machine.

I installed python using brew and matplotlib using pip.

Best regards,

Petar

12.5.0 Darwin Kernel Version 12.5.0: Sun Sep 29 13:33:47 PDT 2013; root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64

Using python 2.7.5 and matplotlib 1.4.0 on mac OSX 10.8.5.

The output of the following snippet:

>import matplotlib.pyplotas plt
plt.ion()
print "Is interactive:?", plt.isinteractive()
>

when ran from shell ($ python snippet.py) is:

Is interactive? : 0

i.e. interactive mode does not work.

I think that this is not the expected behaviour. How can this be fixed?

This is under discussion here: https://github.com/matplotlib/matplotlib/issues/3505

Eric

ยทยทยท

On 2014/09/21, 6:07 AM, Petar Bakalov wrote:

The same code produces

Is interactive? : 1

(i.e. works fine) when ran in an interactive python terminal on the same
machine.

I installed python using brew and matplotlib using pip.

Best regards,
Petar

12.5.0 Darwin Kernel Version 12.5.0: Sun Sep 29 13:33:47 PDT 2013;
root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64

------------------------------------------------------------------------------
Slashdot TV. Video for Nerds. Stuff that Matters.
http://pubads.g.doubleclick.net/gampad/clk?id=160591471&iu=/4140/ostg.clktrk

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users