PDF bug in stable release

Sorry for the confusion - I meant to say that *if* the other bug only
occurs in some newer versions, you could try the patch. But if I
understand your message correctly, it seems that you can't compile
matplotlib on OS X at all, so the patch is not useful for you.

Have you tried the instructions in release/osx/README? It seems that on
OS X it is easy to accidentally install a combination of libraries that
will cause build problems with matplotlib:

http://matplotlib.sourceforge.net/users/installing.html#build-osx

Jouni

Michael Hearne <mhearne@...751...> writes:

···

Jouni - When you say that the FreeType issue is caused by changes in "newer" versions of matplotlib, are those versions more recent than revision 7900, or before?

I assumed "more recent", and so I checked out revision 7901, edited make.osx to point PREFIX to a local directory, renamed it to "Makefile", and ran setup.py build and install. The resulting ftfont.so file still has the "_FT_Attach_File" symbol undefined, and I get the same error as in my bug report.

How old a revision do I need in order to avoid the FreeType issue?

Incidentally, I'm seeing the same FreeType issue on RedHat Linux. Is everybody experiencing this bug, or is it perhaps related to EPD (the Python on both my Mac and RHEL boxes).

--Mike
On Mar 11, 2010, at 1:24 PM, Jouni K. Seppänen wrote:

Michael Hearne <mhearne@...751...> writes:

2) Patch my current code with the fix already in SVN. I would need
someone to point me to the relevant files, and give me some pointers
on applying the patch.

The bug was fixed in revision 7900, and revision 7899 introduced a check
in the pdf backend that raises an exception instead of outputting
invalid pdf. If you can build some old revisions (and your FreeType issue
is caused by some newer changes in matplotlib) you could apply just
these changes to a buildable revision and see if it works.

--
Jouni K. Seppänen
http://www.iki.fi/jks