I noticed that this didn't exist and I never seem to want a frame anyway so here's a patch. I wasn't sure if anything in doc/ needed to be changed...
I don't really like the name "legend.frameon". I'd rather have "legend.frame" or "legend.useframe". If people would accept changing the name of the keyword, then this patch probably shouldn't be committed.
legend_rcparams_frameon.diff (3.08 KB)