OS X: upgrade to X11 1.1.3 breaks mpl

OS X: upgrade to X11 1.1.3 breaks
mpl
Using an automatic update, I upgraded my Darwin X server to X11
1.1.3. Now my matplotlib installation is broken (see below).

Do I need to re-install everything? I am worried about
incompatibilities between numpy, matplotlib and scipy. I’ve been
reading about this in the email lists, and so I’ve wanted to keep my
versions stable.

Can anyone recommend binaries that work with my python version
and gcc?

Python 2.4.1 (#2, Mar 31 2005,
00:05:10)

[GCC 3.3 20030304 (Apple Computer, Inc. build 1666)] on
darwin

I am staying away from fink and MacPorts (Darwinports). I
installed these earlier either with binary packages or from
source.

I had a great system working! Thanks for your help.

On another note, my entire system is now broken. The computer
runs dog slow. I looked at the logs on the mac and noticed the
following (not sure it is relevant):

XFree86 Version 4.4.0 / X Window System

(protocol Version 11, revision 0, vendor release 6600)

[DRI] screen 0 installation complete

Screen 0 added: 1920x1200 @ (0,0)
Could not init font path element
/usr/X11R6/lib/X11/fonts/CID/, removing from list!

More info below.

-Tony

import numpy as N

N.version

‘0.9.6’

import matplotlib

matplotlib.version

‘0.87.2’

import pylab as PLT

Traceback (most recent call last):

File “”, line 1, in ?

File
“/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/pylab.py”, line 1, in ?

from matplotlib.pylab import *

File
“/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/pylab.py”, line 200, in ?

from axes import Axes, PolarAxes

File
“/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/axes.py”, line 15, in ?

from axis import XAxis, YAxis

File
“/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/axis.py”, line 25, in ?

from font_manager import FontProperties

File
“/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/font_manager.py”, line 39, in
?

from matplotlib import ft2font

ImportError: Failure linking new module:
/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/ft2font.so: Library not loaded:
/usr/X11R6/lib/libfreetype.6.dylib

Referenced from:
/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/matplotlib/ft2font.so

Reason: Incompatible library version: ft2font.so requires
version 10.0.0 or later, but libfreetype.6.dylib provides version
6.3.0

I note that in /usr/X11R6/lib that softlinks to the libraries
mentioned above were recently changed:

/usr/X11R6/lib

jplajm:8:lib $ ll libfree*

-rwxr-xr-x 1 root wheel 1786588 Apr 28
2006 libfreetype.6.3.8.dylib

-rw-r–r-- 1 root wheel 683560 Nov
6 17:31 libfreetype.6.3.dylib

lrwxr-xr-x 1 root
wheel 21 Nov 21 09:07
libfreetype.6.dylib -> libfreetype.6.3.dylib

-rw-r–r-- 1 root wheel 1907688 Apr 28
2006 libfreetype.a

lrwxr-xr-x 1 root
wheel 21 Nov 21 09:07
libfreetype.dylib -> libfreetype.6.3.dylib

-rwxr-xr-x 1 root wheel
836 Apr 28 2006 libfreetype.la


<details class='elided'>
<summary title='Show trimmed content'>&#183;&#183;&#183;</summary>

--

Tony Mannucci

Supervisor, Ionospheric and Atmospheric Remote Sensing Group

Mail-Stop
138-308,
Tel > (818) 354-1699

Jet Propulsion
Laboratory, Fax > (818) 393-5115

California Institute of Technology,
Email > Tony.Mannucci@…369…

4800 Oak Grove
Drive,
http://genesis.jpl.nasa.gov

Pasadena, CA 91109