[Numpy-discussion] Going to cut NumPy 1.0b5 tonight

With matplotlib 0.87.5 shortly after.....

···

---------- Forwarded message ----------
From: Travis Oliphant <oliphant.travis@...292...>
Date: Sep 4, 2006 7:55 PM
Subject: [Numpy-discussion] Going to cut NumPy 1.0b5 tonight
To: Discussion of Numerical Python <numpy-discussion@lists.sourceforge.net>

This is a last reminder that I'm going to cut a release of NumPy 1.0b5
tonight. Please have any fixes and/or problems worked out before then.

-Travis

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Numpy-discussion mailing list
Numpy-discussion@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/numpy-discussion

1.0b5
Fails to compile?

numpy/core/src/arrayobject.c:2694: error: request for member 'ob_type' in something not a structure or union

Mac OS X 10.4.7
i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5363)
python 2.5c1

···

On Sep 4, 2006, at 7:00 PM, Charlie Moad wrote:

---------- Forwarded message ----------
From: Travis Oliphant <oliphant.travis@...292...>
Date: Sep 4, 2006 7:55 PM
Subject: [Numpy-discussion] Going to cut NumPy 1.0b5 tonight
To: Discussion of Numerical Python <numpy-discussion@lists.sourceforge.net>

This is a last reminder that I'm going to cut a release of NumPy 1.0b5
tonight. Please have any fixes and/or problems worked out before then.

-Travis

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Numpy-discussion mailing list
Numpy-discussion@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/numpy-discussion

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

Very sorry: here is the initial error:
numpy/core/src/arrayobject.c:564: error: 'op' undeclared (first use in this function)

···

On Sep 5, 2006, at 12:01 AM, Boyd Waters wrote:

1.0b5
Fails to compile?

1.0b5 compiles, with this patch:

patch-arrayobject.c.diff (745 Bytes)

I also get a compile error when trying to build against the win32-py2.4 release.

src\_na_nxutils.c(213) : error C2275: 'PyObject' : illegal use of this
type as an expression
c:\Python24\include\object.h(104) : see declaration of 'PyObject'
src\_na_nxutils.c(213) : error C2065: 'ret' : undeclared identifier
src\_na_nxutils.c(215) : warning C4047: 'return' : 'PyObject *'
differs in levels of indirection from 'int'

Do we need to modify our use of the c-api at all?

- Charlie

···

On 9/5/06, Boyd Waters <bwaters@...451...> wrote:

Very sorry: here is the initial error:
numpy/core/src/arrayobject.c:564: error: 'op' undeclared (first use
in this function)

On Sep 5, 2006, at 12:01 AM, Boyd Waters wrote:

> 1.0b5
> Fails to compile?

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

Thanks for the patch. I am going to hold off until we hear from
Travis. I don't want to distribute anything built from a patched
numpy.

- Charlie

···

On 9/5/06, Boyd Waters <bwaters@...451...> wrote:

1.0b5 compiles, with this patch:

does that look right?

- boyd

Boyd Waters
Scientific Programmer
National Radio Astronomy Observatory
http://www.aoc.nrao.edu

On Sep 5, 2006, at 12:05 AM, Boyd Waters wrote:

> Very sorry: here is the initial error:
> numpy/core/src/arrayobject.c:564: error: 'op' undeclared (first use
> in this function)
>
> On Sep 5, 2006, at 12:01 AM, Boyd Waters wrote:
>
>> 1.0b5
>> Fails to compile?
>

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel