More than one subplot fails when embedding in Tk

I am now able to create multiple figures, each with one

    > or more subplots with my software. What a great
    > collection of software. Thanks for all the work.

Great, glad it helped. I was pretty sure that was the answer.

    > I tried using mx.datetime to create an mx.datetime
    > instance which worked fine. However, mx2num() fails with
    > python claiming an undefined mxdates. I checked the
    > source and found only one mxdates. No idea how it should
    > be defined. In the mean time I am using a datetime
    > instance but I lose a small bit of precision with only
    > integer seconds.

Oops, replace mx2num in matplotlib/ with

def mx2num(mxdates):
    Convert mx datetime instance (or sequence of mx instances) to the
    new date format,
    scalar = False
    if not iterable(mxdates):
        scalar = True
        mxdates = [mxdates]
    ret = epoch2num([m.ticks() for m in mxdates])
    if scalar: return ret[0]
    else: return ret

Thanks for the report!