Matplotlib-users Digest, Vol 9, Issue 24

Dear Eric,

Many thanks for your help. The code runs fine from the command line and
the graph is output as expected with the axis titles formatted correctly.




On 24/04/2016 17:00, matplotlib-users-request at wrote:

Send Matplotlib-users mailing list submissions to
  matplotlib-users at

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
  matplotlib-users-request at

You can reach the person managing the list at
  matplotlib-users-owner at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Matplotlib-users digest..."

Today's Topics:

    1. Re: Render plot labels with LaTeX (Eric Firing)
    2. Re: errors when mp4 files played in browser (gml at


Message: 1
Date: Sat, 23 Apr 2016 07:35:46 -1000
From: Eric Firing <efiring at>
To: matplotlib-users at
Subject: Re: [Matplotlib-users] Render plot labels with LaTeX
Message-ID: <b917503c-252a-9ae0-91c4-d5e200f8e573 at>
Content-Type: text/plain; charset=windows-1252; format=flowed

On 2016/04/23 3:09 AM, Ruth Sims wrote:

Running Matplotlib v: 1.5.1 in Anaconda on OS X El Capitan, V 10.11.4
trying to render plot labels with LaTeX so I can use figures in my
thesis. However, whenever I uncomment the command 'usetex = true', I
receive an error similar to the below:

RuntimeError: LaTeX was not able to process the following string:
Here is the full report generated by LaTeX:

I have MacTeX-2015 and LaTeX, dvipng and ghostscript are each on my
PATH. According to the instructions on
I was able to reproduce the code in a clean environment - so I assume
there is nothing wrong with any of the installations.

Ruth, if you put the code from your first attachment in a file, and run
that file as a script from the command line instead of within ipython,
do you still get the error? It looks like even in your "clean
environment", some ipython startup code is being run (importing sympy,
etc.). There are also other places where pieces of old environment
might be getting pulled in, such as from a matplotlibrc file.


I've tried most of the suggestions I found on various mailing lists but
still received the same error.

Ruth Sims

Matplotlib-users mailing list
Matplotlib-users at


Message: 2
Date: Sat, 23 Apr 2016 14:44:07 -0400
From: gml at
To: Sebastian Berg <sebastian at>
Cc: matplotlib-users at
Subject: Re: [Matplotlib-users] errors when mp4 files played in
Message-ID: <99c9d63eff830aac346c5601d2609ea2 at>
Content-Type: text/plain; charset=US-ASCII; format=flowed

Thanks, Sebastian. That sounds hopeful. What extra arguments did you
add? I'd like to give it a try to see if it fixes the problem I'm
having. ... Gary

On 2016-04-22 02:33, Sebastian Berg wrote:

I had similar problems recently due to ffmpeg changing some defaults
for the encoding. After realizing this was the problem, searching for
it and adding the correct extra arguments for the movie creation to be
passed to ffmpeg quickly solved the issue.

- Sebastian

On Do, 2016-04-21 at 22:45 -0600, Ryan May wrote:

My question then comes to this: does anyone on the matplotlib forum
have experience with viewing mp4 files in a browser? If so, do you
have any suggestions for a work-around? I've literally spent months
getting a few matplotlib animations to the point where they may be
useful to others. It never occurred to me that I'd have problems at
the very last link in the chain.

Thanks very much for your thoughts. Sorry this is so long.

I've put some effort into making sure the animations will render in
the Jupyter Notebook, so I'm curious: on the platforms where you're
seeing problems, what do they do with the movie at the bottom of this



Ryan May

Matplotlib-users mailing list
Matplotlib-users at

Matplotlib-users mailing list
Matplotlib-users at


Subject: Digest Footer

Matplotlib-users mailing list
Matplotlib-users at


End of Matplotlib-users Digest, Vol 9, Issue 24