Matplotlib "show()" error Mac OS X Lion

Sorry it seems that the group as a limit to mail size so I am resending the mail below without the attachment.


Begin forwarded message:

From: Bedartha Goswami <goswami@…3385…99…>

Subject: Re: [Matplotlib-users] Matplotlib “show()” error Mac OS X Lion

Date: November 11, 2011 4:36:11 PM GMT+01:00



As a test, try to set your backend to either ‘cocoaagg’ or ‘macosx’ like so:

import matplotlib as mpl

I tried doing the above but this required me to install something called PyObjC:

The CococaAgg backend required PyObjC to be installed!
(currently testing v1.3.7)

when I tried to easy_install PyObjC it gave me the following error:

Unknown distribution option: ‘use_2to3’
error: Could not find required distribution pyobjc-core

I suspect you are trying to install matplotlib on the 64-bit Python
instead of the 32-bit python for which it was built

Well, I do use the python-32 bit version for all the work and in fact, the bumpy and scipy have been built for the python-32 bit. and i am having trouble with matplotlib on this - in fact, none of the bumpy, scipy, and python etc modules even load on the 64-bit version.

Download and unpack the matplotlib source.
Edit and change the entry for darwin to include those two
directories: /usr/X11 and /usr/lib.

I did try this way as well, but the build does not manage to detect the libpng15 library in the X11 directory - somehow it uses “lpng15” marker and does not end up finding it when it is right there under X11’s nose. I am attaching the detailed shell text for this step with this mail.