Matplotlib on OS X 10.4 (was: can't import pylab)

John Seales <praxbaffle@...32...> writes:

I'm using Mac os 10.4.11. Python is included in mac os.

The error messages refer to Python 2.6:

> ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/matplotlib/ft2font.so, 2): Library not loaded: /usr/X11R6/lib/libfreetype.6.dylib
> Referenced from: /Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/matplotlib/ft2font.so

If you are somehow using this with the system Python, it's no wonder
that you are having problems. I think OS X 10.4 includes Python 2.3 or
at most 2.4 - version 10.5 has Python 2.5. But perhaps you have
installed some other version of Python - one way to test what you are
using is to look at where Python gets its modules:

~% python
Python 2.5.2 (r252:60911, Feb 22 2008, 07:57:53)
[GCC 4.0.1 (Apple Computer, Inc. build 5363)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

import os
os

<module 'os' from '/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/os.pyc'>

(So I am using something else than the system-supplied Python, whose
os.pyc file is under /System/Library.)

Some distributions of Python for OS X are mentioned here:
http://matplotlib.sourceforge.net/faq/installing_faq.html#which-python-for-osx

Matplotlib I installed from a precompiled version.

Is this the version from Sourceforge, or somewhere else?

Anyway, the library linking problems sound a lot like you are using
software that was not compiled for your version of OS X - I guess most
developers have upgraded to Leopard quite some time ago, so they would
not notice if something breaks on older releases.

The larger question is, which versions of OS X should be supported by
the binary packages? The ReadMe.txt bundled with the MacPython 2.6.2
installer says:

    This package will install MacPython 2.6.2 for Mac OS X
    10.3 or later for the following
    architecture(s): i386, ppc.

So Python itself supports Panther and newer, and I think the compiler
flags used by Python are inherited by extensions - but if there is
something other than just compiler flags to worry about, someone would
have to have an installation of the target version of OS X to test on.

···

--
Jouni K. Sepp�nen
http://www.iki.fi/jks

I’ve been using python 2.6 for several months. I can’t remember how I installed it.
Matplotlib is from sourceforge. Filename: matplotlib-0.98.5.2-py2.5-mpkg.zip.

···

To: matplotlib-users@lists.sourceforge.net
From: jks@…397…
Date: Tue, 21 Apr 2009 10:10:10 +0300
Subject: [Matplotlib-users] Matplotlib on OS X 10.4 (was: can’t import pylab)

John Seales <praxbaffle@…32…> writes:

I’m using Mac os 10.4.11. Python is included in mac os.

The error messages refer to Python 2.6:

ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/matplotlib/ft2font.so, 2): Library not loaded: /usr/X11R6/lib/libfreetype.6.dylib
Referenced from: /Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/matplotlib/ft2font.so

If you are somehow using this with the system Python, it’s no wonder
that you are having problems. I think OS X 10.4 includes Python 2.3 or
at most 2.4 - version 10.5 has Python 2.5. But perhaps you have
installed some other version of Python - one way to test what you are
using is to look at where Python gets its modules:

~% python
Python 2.5.2 (r252:60911, Feb 22 2008, 07:57:53)
[GCC 4.0.1 (Apple Computer, Inc. build 5363)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

import os
os
<module ‘os’ from ‘/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/os.pyc’>

(So I am using something else than the system-supplied Python, whose
os.pyc file is under /System/Library.)

Some distributions of Python for OS X are mentioned here:
http://matplotlib.sourceforge.net/faq/installing_faq.html#which-python-for-osx

Matplotlib I installed from a precompiled version.

Is this the version from Sourceforge, or somewhere else?

Anyway, the library linking problems sound a lot like you are using
software that was not compiled for your version of OS X - I guess most
developers have upgraded to Leopard quite some time ago, so they would
not notice if something breaks on older releases.

The larger question is, which versions of OS X should be supported by
the binary packages? The ReadMe.txt bundled with the MacPython 2.6.2
installer says:

This package will install MacPython 2.6.2 for Mac OS X
10.3 or later for the following
architecture(s): i386, ppc.

So Python itself supports Panther and newer, and I think the compiler
flags used by Python are inherited by extensions - but if there is
something other than just compiler flags to worry about, someone would
have to have an installation of the target version of OS X to test on.


Jouni K. Seppänen
http://www.iki.fi/jks


Stay on top of everything new and different, both inside and
around Java ™ technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p


Matplotlib-users mailing list
Matplotlib-users@…563…eforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users


Rediscover Hotmail®: Now available on your iPhone or BlackBerry Check it out.