Matplotlib Installation error

Hi folks,

Sorry to bother you with an installationg problem. But I really want to get
matplotlib.
I have Windows 8 (64) and python 2.7, I've succesfully fully installed
pygame and numpy. When I start the installation of matplotlib (I've tried
1.4.0 and 1.4.2) I get an error message telling that python 2.7 were not
found in the registry. I've tried to save it in the same registry as python
2.7 befor executing the installation but I still recieve the same error
message.

I'm greatfull for all help!

/ M.S

···

--
View this message in context: http://matplotlib.1069221.n5.nabble.com/Matplotlib-Installation-error-tp44643.html
Sent from the matplotlib - users mailing list archive at Nabble.com.

Make sure to use matplotlib-1.4.2.win32-py2.7.exe if you have installed python-2.7.x.msi (32 bit).

Matplotlib requires extra Python packages. See <http://matplotlib.org/users/installing.html#windows>.

In case you have Python 2.7.9 and numpy installed you can easily install matplotlib and all required packages with pip:

   C:\Python27\Scripts\pip.exe install matplotlib

Christoph

···

On 12/17/2014 11:33 PM, MIS_91 wrote:

Hi folks,

Sorry to bother you with an installationg problem. But I really want to get
matplotlib.
I have Windows 8 (64) and python 2.7, I've succesfully fully installed
pygame and numpy. When I start the installation of matplotlib (I've tried
1.4.0 and 1.4.2) I get an error message telling that python 2.7 were not
found in the registry. I've tried to save it in the same registry as python
2.7 befor executing the installation but I still recieve the same error
message.

I'm greatfull for all help!

/ M.S

Christoph,

When did pip.exe start being packaged with python2.7? I thought that was only in one of the py3k releases?

Ben Root

···

On Thu, Dec 18, 2014 at 3:17 AM, Christoph Gohlke <cgohlke@…83…2143…> wrote:

On 12/17/2014 11:33 PM, MIS_91 wrote:

Hi folks,

Sorry to bother you with an installationg problem. But I really want to get

matplotlib.

I have Windows 8 (64) and python 2.7, I’ve succesfully fully installed

pygame and numpy. When I start the installation of matplotlib (I’ve tried

1.4.0 and 1.4.2) I get an error message telling that python 2.7 were not

found in the registry. I’ve tried to save it in the same registry as python

2.7 befor executing the installation but I still recieve the same error

message.

I’m greatfull for all help!

/ M.S

Make sure to use matplotlib-1.4.2.win32-py2.7.exe if you have installed

python-2.7.x.msi (32 bit).

Matplotlib requires extra Python packages. See

<http://matplotlib.org/users/installing.html#windows>.

In case you have Python 2.7.9 and numpy installed you can easily install

matplotlib and all required packages with pip:

C:\Python27\Scripts\pip.exe install matplotlib

Christoph


Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server

from Actuate! Instantly Supercharge Your Business Reports and Dashboards

with Interactivity, Sharing, Native Excel Exports, App Integration & more

Get technology previously reserved for billion-dollar corporations, FREE

http://pubads.g.doubleclick.net/gampad/clk?id=164703151&iu=/4140/ostg.clktrk


Matplotlib-users mailing list

Matplotlib-users@lists.sourceforge.net

https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Hi,

I got that problem when I tried to install a 64-bit pacakge on a 32-bit python installation.

If you want 64-bit, make sure you download the 64-bit version from python.org.

For the rest of the 64-bit packages I usually go to Christoph's site:

http://www.lfd.uci.edu/~gohlke/pythonlibs/

Armando

···

On 18/12/2014 08:33, MIS_91 wrote:

Hi folks,

Sorry to bother you with an installationg problem. But I really want to get
matplotlib.
I have Windows 8 (64) and python 2.7, I've succesfully fully installed
pygame and numpy. When I start the installation of matplotlib (I've tried
1.4.0 and 1.4.2) I get an error message telling that python 2.7 were not
found in the registry. I've tried to save it in the same registry as python
2.7 befor executing the installation but I still recieve the same error
message.

I'm greatfull for all help!

/ M.S

--
View this message in context: http://matplotlib.1069221.n5.nabble.com/Matplotlib-Installation-error-tp44643.html
Sent from the matplotlib - users mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=164703151&iu=/4140/ostg.clktrk
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Pip and setuptools were added in 2.7.9. From the release announcement:

- The "ensurepip" module has been backported to Python 2.7

Christoph

···

On 12/18/2014 6:37 AM, Benjamin Root wrote:

Christoph,

When did pip.exe start being packaged with python2.7? I thought that was
only in one of the py3k releases?

Ben Root

On Thu, Dec 18, 2014 at 3:17 AM, Christoph Gohlke <cgohlke@…2143… > <mailto:cgohlke@…2143…>> wrote:

    On 12/17/2014 11:33 PM, MIS_91 wrote:
    > Hi folks,
    >
    > Sorry to bother you with an installationg problem. But I really want to get
    > matplotlib.
    > I have Windows 8 (64) and python 2.7, I've succesfully fully installed
    > pygame and numpy. When I start the installation of matplotlib (I've tried
    > 1.4.0 and 1.4.2) I get an error message telling that python 2.7 were not
    > found in the registry. I've tried to save it in the same registry as python
    > 2.7 befor executing the installation but I still recieve the same error
    > message.
    >
    > I'm greatfull for all help!
    >
    > / M.S
    >

    Make sure to use matplotlib-1.4.2.win32-py2.7.exe if you have installed
    python-2.7.x.msi (32 bit).

    Matplotlib requires extra Python packages. See
    <http://matplotlib.org/users/installing.html#windows>.

    In case you have Python 2.7.9 and numpy installed you can easily install
    matplotlib and all required packages with pip:

        C:\Python27\Scripts\pip.exe install matplotlib

    Christoph

    ------------------------------------------------------------------------------
    Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
    from Actuate! Instantly Supercharge Your Business Reports and Dashboards
    with Interactivity, Sharing, Native Excel Exports, App Integration &
    more
    Get technology previously reserved for billion-dollar corporations, FREE
    http://pubads.g.doubleclick.net/gampad/clk?id=164703151&iu=/4140/ostg.clktrk
    _______________________________________________
    Matplotlib-users mailing list
    Matplotlib-users@lists.sourceforge.net
    <mailto:Matplotlib-users@lists.sourceforge.net>
    https://lists.sourceforge.net/lists/listinfo/matplotlib-users