matplotlib ignoring .matplotlibrc?

I installed the matplotlib-1.52.win32-py2.3 binary on
python23 (Enthought). I don't want to install a lot
of extra packages so I found the existing
.matplotlibrc in C:\Python23\share\matplotlib and
modified the backend to "backend : TkAgg". But
when I try to import matplotlib it appears to be still
looking for the default Gtk backend.

I noticed that sys.path did not contain
C:\Python23\share\matplotlib so I tried adding it.
Still no luck.

Here's the error message:

IDLE 1.0 ==== No Subprocess ====

from matplotlib.matlab import *

No module named pygtk
matplotlib requires pygtk-1.99.16 or greater -- trying
anyway. Please hold on
Traceback (most recent call last):
  File "<pyshell#0>", line 1, in ?
    from matplotlib.matlab import *
  File
"C:\Python23\Lib\site-packages\matplotlib\matlab.py",
line 127, in ?
    from backends import new_figure_manager,
error_msg, \
  File
"C:\Python23\Lib\site-packages\matplotlib\backends\__init__.py",
line 16, in ?
    from backend_gtk import \
  File
"C:\Python23\Lib\site-packages\matplotlib\backends\backend_gtk.py",
line 13, in ?
    import gobject
ImportError: No module named gobject

Any ideas on why this does not work? Should my python
path contain the path to share\matplotlib ?
-- David

···

__________________________________
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.
http://taxes.yahoo.com/filing.html