matplotlib egg finds wrong version of numpy

Hello,

I am having a problem installing matplotlib 0.93.3 from egg on Mac OSX 10.5.5. Even though I have numpy 1.2.1 installed in /Library/Frameworks/..., the egg insists on using an older version of numpy (1.0.4) in /opt/local/lib/python2.5/site-packages (which must have been delivered with the OS). How can I tell the egg where to find the proper version of numpy? Thanks!

-- Jeff

Jeff Mangum wrote:

Hello,

I am having a problem installing matplotlib 0.93.3 from egg on Mac OSX 10.5.5. Even though I have numpy 1.2.1 installed in /Library/Frameworks/..., the egg insists on using an older version of numpy (1.0.4) in /opt/local/lib/python2.5/site-packages (which must have been delivered with the OS).

No, /opt/local is MacPorts territory.

How can I tell the egg where to find the proper version of numpy? Thanks!

Are you sure you are using the same versions of Python to run and install both of these?

···

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco

Robert Kern-2 wrote:

Jeff Mangum wrote:

Hello,

I am having a problem installing matplotlib 0.93.3 from egg on Mac OSX
10.5.5. Even though I have numpy 1.2.1 installed in
/Library/Frameworks/..., the egg insists on using an older version of
numpy (1.0.4) in /opt/local/lib/python2.5/site-packages (which must have
been delivered with the OS).

No, /opt/local is MacPorts territory.

How can I tell the egg where to find the
proper version of numpy? Thanks!

Are you sure you are using the same versions of Python to run and install
both
of these?

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma
  that is made terrible by our own mad attempt to interpret it as though
it had
  an underlying truth."
   -- Umberto Eco

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's
challenge
Build the coolest Linux based applications with Moblin SDK & win great
prizes
Grand prize is a trip for two to an Open Source event anywhere in the
world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Pretty sure that I am using the same versions of python to run and install.
Here is the trace when I try to install matplotlib:

torgo:Desktop jmangum$ easy_install
./matplotlib-0.98.3-py2.5-macosx-10.3.egg
Processing matplotlib-0.98.3-py2.5-macosx-10.3.egg
removing
'/Library/Python/2.5/site-packages/matplotlib-0.98.3-py2.5-macosx-10.3.egg'
(and everything under it)
creating
/Library/Python/2.5/site-packages/matplotlib-0.98.3-py2.5-macosx-10.3.egg
Extracting matplotlib-0.98.3-py2.5-macosx-10.3.egg to
/Library/Python/2.5/site-packages
matplotlib 0.98.3 is already the active version in easy-install.pth

Installed
/Library/Python/2.5/site-packages/matplotlib-0.98.3-py2.5-macosx-10.3.egg
Processing dependencies for matplotlib==0.98.3
Searching for matplotlib==0.98.3
Reading http://pypi.python.org/simple/matplotlib/
Reading http://matplotlib.sourceforge.net
Reading
https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=278194
Reading
https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=82474
Reading http://sourceforge.net/project/showfiles.php?group_id=80706
Best match: matplotlib 0.98.3
Downloading
http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.3.tar.gz?modtime=1217773039&big_mirror=0
Processing matplotlib-0.98.3.tar.gz
Running matplotlib-0.98.3/setup.py -q bdist_egg --dist-dir
/var/folders/P-/P-e5QX4vHmezGAqqg2iH1k++C86/-Tmp-/easy_install-wEpzrD/matplotlib-0.98.3/egg-dist-tmp-Op3Pcx

···

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]
              platform: darwin

REQUIRED DEPENDENCIES
                        * numpy 1.1 or later is required; you have 1.0.1
error: Setup script exited with 1

Thanks for your help!

-- Jeff

--
View this message in context: http://www.nabble.com/matplotlib-egg-finds-wrong-version-of-numpy-tp20544369p20570681.html
Sent from the matplotlib - users mailing list archive at Nabble.com.

Jeff Mangum wrote:

Robert Kern-2 wrote:

Jeff Mangum wrote:

Hello,

I am having a problem installing matplotlib 0.93.3 from egg on Mac OSX
10.5.5. Even though I have numpy 1.2.1 installed in
/Library/Frameworks/..., the egg insists on using an older version of
numpy (1.0.4) in /opt/local/lib/python2.5/site-packages (which must have
been delivered with the OS).

No, /opt/local is MacPorts territory.

How can I tell the egg where to find the
proper version of numpy? Thanks!

Are you sure you are using the same versions of Python to run and install
both
of these?

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma
  that is made terrible by our own mad attempt to interpret it as though
it had
  an underlying truth."
   -- Umberto Eco

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's
challenge
Build the coolest Linux based applications with Moblin SDK & win great
prizes
Grand prize is a trip for two to an Open Source event anywhere in the
world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Pretty sure that I am using the same versions of python to run and
install. Here is the trace when I try to install matplotlib:

torgo:Desktop jmangum$ easy_install
./matplotlib-0.98.3-py2.5-macosx-10.3.egg
Processing matplotlib-0.98.3-py2.5-macosx-10.3.egg
removing
'/Library/Python/2.5/site-packages/matplotlib-0.98.3-py2.5-macosx-10.3.egg'
(and everything under it)
creating
/Library/Python/2.5/site-packages/matplotlib-0.98.3-py2.5-macosx-10.3.egg
Extracting matplotlib-0.98.3-py2.5-macosx-10.3.egg to
/Library/Python/2.5/site-packages
matplotlib 0.98.3 is already the active version in easy-install.pth

Installed
/Library/Python/2.5/site-packages/matplotlib-0.98.3-py2.5-macosx-10.3.egg
Processing dependencies for matplotlib==0.98.3
Searching for matplotlib==0.98.3
Reading http://pypi.python.org/simple/matplotlib/
Reading http://matplotlib.sourceforge.net
Reading
https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=278194
Reading
https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=82474
Reading http://sourceforge.net/project/showfiles.php?group_id=80706
Best match: matplotlib 0.98.3
Downloading
http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.3.tar.gz?modtime=1217773039&big_mirror=0
Processing matplotlib-0.98.3.tar.gz
Running matplotlib-0.98.3/setup.py -q bdist_egg --dist-dir
/var/folders/P-/P-e5QX4vHmezGAqqg2iH1k++C86/-Tmp-/easy_install-wEpzrD/matplotlib-0.98.3/egg-dist-tmp-Op3Pcx

BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]
              platform: darwin

REQUIRED DEPENDENCIES
                        * numpy 1.1 or later is required; you have 1.0.1
error: Setup script exited with 1

Thanks for your help!

-- Jeff

Sorry, but indeed the easy_install is finding the "stock" Apple python
rather than the python.org version I recently installed:

···

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]
              platform: darwin

REQUIRED DEPENDENCIES
                        * numpy 1.1 or later is required; you have 1.0.1
error: Setup script exited with 1
torgo:Desktop jmangum$ which python
/Library/Frameworks/Python.framework/Versions/Current/bin/python
torgo:Desktop jmangum$ python
Python 2.5.2 (r252:60911, Feb 22 2008, 07:57:53)
[GCC 4.0.1 (Apple Computer, Inc. build 5363)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

How can I instruct the matplotlib install to find the appropriate python
install? Thanks!

-- Jeff

--
View this message in context: http://www.nabble.com/matplotlib-egg-finds-wrong-version-of-numpy-tp20544369p20570792.html
Sent from the matplotlib - users mailing list archive at Nabble.com.

Jeff Mangum wrote:

How can I instruct the matplotlib install to find the appropriate python
install? Thanks!

Your easy_install script is the one that comes from OS X's Python. Install setuptools for your www.python.org Python and use the easy_install script that it installs, instead. The Python executable that gets run by the easy_install script is the one which the eggs get installed for.

   http://pypi.python.org/pypi/setuptools

···

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco

Robert Kern-2 wrote:

Jeff Mangum wrote:

How can I instruct the matplotlib install to find the appropriate python
install? Thanks!

Your easy_install script is the one that comes from OS X's Python. Install
setuptools for your www.python.org Python and use the easy_install script
that
it installs, instead. The Python executable that gets run by the
easy_install
script is the one which the eggs get installed for.

   http://pypi.python.org/pypi/setuptools

--
Robert Kern

Thanks Robert. I grabbed setuptools and reinstalled. Unfortunately, even
though I am using the right version of easy_install...

torgo:Desktop jmangum$ which easy_install
/Library/Frameworks/Python.framework/Versions/Current/bin/easy_install

...I still get the same error when installing matplotlib...

···

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]
              platform: darwin

REQUIRED DEPENDENCIES
                        * numpy 1.1 or later is required; you have 1.0.1
error: Setup script exited with 1

-- Jeff

--
View this message in context: http://www.nabble.com/matplotlib-egg-finds-wrong-version-of-numpy-tp20544369p20571600.html
Sent from the matplotlib - users mailing list archive at Nabble.com.

Jeff Mangum wrote:

Thanks Robert. I grabbed setuptools and reinstalled. Unfortunately, even
though I am using the right version of easy_install...

torgo:Desktop jmangum$ which easy_install
/Library/Frameworks/Python.framework/Versions/Current/bin/easy_install

...I still get the same error when installing matplotlib...

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]

This is Apple's Python, not python.org Python.

$ /usr/bin/python
Python 2.5.1 (r251:54863, Apr 15 2008, 22:57:26)
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

$ /Library/Frameworks/Python.framework/Versions/Current/bin/python
Python 2.5.1 (r251:54869, Apr 18 2007, 22:08:04)
[GCC 4.0.1 (Apple Computer, Inc. build 5367)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

···

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco

Robert Kern-2 wrote:

Jeff Mangum wrote:

Thanks Robert. I grabbed setuptools and reinstalled. Unfortunately,
even
though I am using the right version of easy_install...

torgo:Desktop jmangum$ which easy_install
/Library/Frameworks/Python.framework/Versions/Current/bin/easy_install

...I still get the same error when installing matplotlib...

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]

This is Apple's Python, not python.org Python.

$ /usr/bin/python
Python 2.5.1 (r251:54863, Apr 15 2008, 22:57:26)
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

$ /Library/Frameworks/Python.framework/Versions/Current/bin/python
Python 2.5.1 (r251:54869, Apr 18 2007, 22:08:04)
[GCC 4.0.1 (Apple Computer, Inc. build 5367)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma
  that is made terrible by our own mad attempt to interpret it as though
it had
  an underlying truth."
   -- Umberto Eco

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's
challenge
Build the coolest Linux based applications with Moblin SDK & win great
prizes
Grand prize is a trip for two to an Open Source event anywhere in the
world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Hmmm. Got it from python.org (http://python.org/download/releases/2.5.2/)
and just reinstalled to make sure. Indeed the binary is in
/Library/Frameworks/Python.framework/Versions/Current/bin/python.

I am seeing some other problems (like PPC binaries in /opt/local/bin). I
have recently migrated from PPC to Intel Mac, and I suspect that the
migration assistant may have been too thorough...

-- Jeff

···

--
View this message in context: http://www.nabble.com/matplotlib-egg-finds-wrong-version-of-numpy-tp20544369p20572269.html
Sent from the matplotlib - users mailing list archive at Nabble.com.

Jeff Mangum wrote:

Hmmm. Got it from python.org (http://python.org/download/releases/2.5.2/)
and just reinstalled to make sure. Indeed the binary is in
/Library/Frameworks/Python.framework/Versions/Current/bin/python.

I know that you have the python.org Python installed. However, it may not be the Python that the easy_install script is using. Check the contents of the easy_install file. It ought to point to /Library/Frameworks/.../Python at the top. Try explicitly running /Library/Frameworks/.../bin/easy_install instead.

I am seeing some other problems (like PPC binaries in /opt/local/bin). I
have recently migrated from PPC to Intel Mac, and I suspect that the
migration assistant may have been too thorough...

Your PYTHONPATH may also be messed up.

···

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco

Jeff Mangum wrote:

BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26) [GCC
                        4.0.1 (Apple Inc. build 5465)]
              platform: darwin

You'll need to get easy_install to use the right Python anyway, but do you need to build MPL? can you use the binary:

      matplotlib-0.98.3-py2.5-macosx-10.3.egg

(note that that is OS-X 10.3 and above)

you may have to re-name it to:

matplotlib-0.98.3-py2.5.egg

to get easy_install to recognize it.

-CHB

···

--
Christopher Barker, Ph.D.
Oceanographer

Emergency Response Division
NOAA/NOS/OR&R (206) 526-6959 voice
7600 Sand Point Way NE (206) 526-6329 fax
Seattle, WA 98115 (206) 526-6317 main reception

Chris.Barker@...259...

Robert Kern-2 wrote:

Jeff Mangum wrote:

Hmmm. Got it from python.org
(http://python.org/download/releases/2.5.2/)
and just reinstalled to make sure. Indeed the binary is in
/Library/Frameworks/Python.framework/Versions/Current/bin/python.

I know that you have the python.org Python installed. However, it may not
be the
Python that the easy_install script is using. Check the contents of the
easy_install file. It ought to point to /Library/Frameworks/.../Python at
the
top. Try explicitly running /Library/Frameworks/.../bin/easy_install
instead.

I am seeing some other problems (like PPC binaries in /opt/local/bin). I
have recently migrated from PPC to Intel Mac, and I suspect that the
migration assistant may have been too thorough...

Your PYTHONPATH may also be messed up.

--
Robert Kern

The easy_install script checked out ok. Must have been a path issue, as I
was able to get the egg to install after starting a new shell. Seems to
work now. Thanks for your help!

-- Jeff

···

--
View this message in context: http://www.nabble.com/matplotlib-egg-finds-wrong-version-of-numpy-tp20544369p20626848.html
Sent from the matplotlib - users mailing list archive at Nabble.com.