[matplotlib-devel] Delaying rc3 (again)

Yes! I’m sending you a virtual high five! Thanks for thy Russell.


On Tuesday, October 30, 2012, Russell E. Owen wrote:

In article <508FF830.3050901@…920…6…>,

Michael Droettboom <mdroe@…86…>


Agreed! Thanks to everyone for their hard work. I think this has

shaped up to be a great release.

I’m fortunate to have power and connectivity today, so I was able to get

a release tested, tagged and uploaded.

To our binary builders: as able, it would be great to put the binaries

up (or send them to me to do so), and then I’ll make an announcement on

matplotlib-users. I really intend (barring any really serious issues)

this to be the last rc before the 1.2.0 final.

Thanks again,


The Mac binaries are now up. This time it built perfectly on MacOS X

10.4; thanks to the folks that worked so hard fixing those build


The 32-bit version is not well tested because I have neither inkscape

nor ghostscript installed on that ancient system, but it passes the

tests that it can run under those circumstances.

The 64-bit version passes all tests except 2 knownfail and 3 skipped.

– Russell

P.S. I had to build the 64-bit version twice. The first time I tried to

build it using the same directory of code that I used to build 32-bit

version. I first deleted the “build” and “dist” subdirectories and ran

“python setup.py clean”, then built as usual. There were no errors or

warnings during the build, but the unit tests would not run on the

results – complaining of missing modules.

So I built again using a freshly unpacked code directory and that worked

just fine.

I’m pretty sure I’ve seen this problem before, but keep forgetting to

ask about it.

Is this a bug somewhere (e.g. in matplotlib’s setup.py or somewhere in

python) or is there some better way to clear out a python code directory?

Damon McDougall

Mathematics Institute
University of Warwick
West Midlands
United Kingdom