matplotlib can't find pygtk during build

Sorry for the forward... I wanted to make sure this made it to the list.


---------- Forwarded message ----------
From: Stephen Uhlhorn <suhlhorn@...287...>
Date: Feb 4, 2007 8:02 AM
Subject: Re: [Matplotlib-users] matplotlib can't find pygtk during build
To: Christopher Barker <Chris.Barker@...259...>

On 2/3/07, Christopher Barker <Chris.Barker@...259...> wrote:

I'm pretty sure that MPL looks for it by trying to import it. does:

import pygtk

work with the version of Python you're using?

> I followed the python/numpy/scipy installation method here:

Those instructions are for the Universal Framework Python, that you can
get from and That version does not
play so well with Darwinports.

> I installed pygtk (2.10.3) with mac/darwinports on my mac os 10.4
> ppcmachine.

Are you using a darwinports python? that version of pygtk will probably
only work with a darwinports python, and in that case, there may even be
a darwinports matplotlib.

import pygtk barfs. My python is from ActiveState (Framework) which
was recommended by the scipy people.

In general, you need to use all darwinports python stuff or no
darwinports python stuff.

In theory, one could use PyGTK with he Framework build of python, using
Apple's X11, but I've never seen a package for that.

Why do you want to use pygtk on a Mac? why not TK or wx, or even try the
cocoa back-end, though I have no idea what state that is in.

Here's the real saga. I had a working Fink installaiton of
python/numpy/scipy/matplotlib until an update to scipy broke critical
functions (fopen). The fix is in cvs, so this whole mess started in an
attempt to use a cvs version of scipy. So I followed the instructions
on the scipy site and in the link above. Python numpy, and scipy are
fine, but I can't get matplotlib to work with the system.

I tried wxpython2.6 first, but figure windows never got drawn on my
display, even when I used pythonw. So I tried pygtk because it worked
fine for me under fink and on my linux box. I thought I could build a
binary pygtk with darwinports and use it in my installation... I guess

So here we are. What to do? I think these are my options:

1) Build a mpkg of pygtk using darwinports and install it under my
python. Is this possible?

2) Get wx working somehow. Where do I begin?

3) Cocoa backend? I didn't know there was one.

4) Go back to fink or darwinports and fight these problems on the scipy side.

Which course do you (or anyone) recommend?